Problem Updating Emonpi

I hit the update button on my emonpi and it stopped working. When I view the update log it’s all
/bin/sh: 1: /home/pi/emonpi/update: Permission denied

I tried doing a factory refresh and then update and I got the same thing. Suggestions?

There are multiple threads running about problems with updating the emonPi. I suggest you look through those until someone more knowledgeable than me can help you.

Could you please show us your emonpiupdate.log?

Are you able to access the emonPi’s command line via SSH? If so could you post the output of

ls -la /boot/emonSD-*
ls -la /home/pi/emonpi/update
git -C ~/emonpi status

The symptoms you describe are not the same as other recent reports regarding update issues, but that doesn’t mean it’s not related. We just need some more info to determine whats happening.

You could also post the “server info” from the emoncms admin page too perhaps, that might be useful.

[email protected] ~ $ ls -la /boot/emonSD-*
ls: cannot access /boot/emonSD-*: No such file or directory

[email protected] ~ $ ls -la /home/pi/emonpi/update
total 56
drwxr-xr-x 2 pi pi 4096 May 25 19:06 .
drwxr-xr-x 16 pi pi 4096 May 25 19:06
-rwxr-xr-x 1 pi pi 346 May 25 19:06 emoncmsdbupdate.php
-rwxr-xr-x 1 pi pi 11495 May 25 19:06 emoncms.sh
-rwxr-xr-x 1 pi pi 1355 May 25 19:06 emonhub.sh
-rwxr-xr-x 1 pi pi 671 May 25 19:06 emonpi.sh
-rwxr-xr-x 1 pi pi 1458 May 25 19:06 install_emoncms_service.sh
-rwxr-xr-x 1 pi pi 5522 May 25 19:06 main.sh
-rw-r–r-- 1 pi pi 726 May 25 19:06 readme.md
-rwxr-xr-x 1 pi pi 732 May 25 19:06 remove_emoncms_service.sh
-rwxr-xr-x 1 pi pi 1359 May 25 19:06 rfm69pi.sh
[email protected] ~ $

There is no emonpiupdate.log. I think my emonpi is too old. It’s a model B. Does the update function not work if it’s a B?

What version of emoncms are you running?

That’s what I suspect, the earlier sd card images are not compatible with the current updater, I’m afraid that running the update will have made changes to you setup, At this point I’m unsure if we can restore it as it’s not clear what changes would have been made exactly. A desision needs to be made with regard to investing time in trying to restore this old image or just starting a fresh with a new image. Do you have a new/spare sdcard and/or a USB micro-sdcard reader? Since you already did a factory reset, I suspect the new image route might appeal?

Do you mean a RPi 2B ?

Is this a shop bought emonpi? AFAIA they only came with 2or3 B’s not the (1) B’s.

Either way, the emonSD images should still work fine with a B or 2B, just needs a minor edit to the config.txt file before putting it in the Pi.

Thanks… I think so too. I’m in the process of trying to flash a new card. I’m trying to use the latest 2018 image.

I’m not sure which RPI it is. I bought it with the card. It came with a 4 gb card and when I opened it the RPI says it’s a B but I don’t know if that’s a 1 or 2 B. If they only made them with the 2B, then that must be it. It doesn’t have the old video hook up so I think you are right - it must be a 2B. I’ll try with this new image and see what happens. Thanks.

The updater shouldn’t have tried to update it if it wasn’t possible. Ah well.

Im sorry about that, there was a mistake in the safe update check in earlier versions that resulted in the updater continuing regardless. Do you know which version of the image you tried updating from?