Community
OpenEnergyMonitor

Community

Problem connecting emonESP/EmonTX with emoncms local on RPi


(Bert Tammer) #1

Hi all,
I am new to OEM and just received my EmonTXv3 with AC-AC PSU, emonESP Huzzah, CT’s and the emoncms SD-Card for my Raspberry Pi 3.
I am following this guide: Using the EmonTx V3 With the ESP8266 Huzzah WIFI Module

I did pay attention that the EmonTX with the emonESP requires the AC-AC adapter AND the 5V USB power supply; with the removal of jumper JP2.
I was able to open the emonESP configuration page and added my wifi credentials. So far so good.
Next opening the emonESP configuration page (on 192.168.178.61) and here i run into an issue for which did not found an answer on the Guide or in this forum.
I try to configure the Emoncms server as my local RPi3 (with the bought sd-card) and fill the [email protected] from this RPI3 as My emoncms.
Btw the emoncms is running on the RPi3.
Doing this i get this error message


I tried to use different formats for the emoncms url, with http:// , with or without the page emoncms,
but i keep getting this error.

Hopefully someone can help me here or point me to the Guide page where is explained how to configure emonESP with a local running emoncms (on RPi).

Kind regards, Bert


(ian) #3

Have you put in a node name?
Nothing visible in your screen shot.


(Bert Tammer) #4

Hi Ian, Yes, my mistake. I did not fill in the Write apikey :frowning: . I was in the impression that this was only needed by use of the Emoncms.org site. But a video showed me the config for a local emoncms config.
Now i see my EmonTX and i am getting data from it. I installed two CT’s, ct1 for the house input power and ct2 for my solar panels output.
I followed this video emonPi Emoncms V9 - Logging Inputs to Feeds and created for each ct1 and ct2, two Feeds (Log to Feed and Power to KWh) but i am only receiving data from ct2 (Solar). Ct1 does not give any data. Perhaps the CT is positioned in the wrong direction? I turn the ct and see what it is doing then.
I can’t seem to find a description or video which describes my situation; a EmonTX with emonESP and a local emoncms on RPi3.
This is what i see in emoncms:

EDIT: I turned the CT1, restarted EmonTX, and then i receive negative values from this ct. So it was correctly installed in the first place. Again turned the CT1 and now i am receiving values (positive)…

EDIT 2: I see that the data for ct1 one moment reeds 0, an other moment it gives a value:



This does not seems to me as correct?.. Any ideas about this behaviour?
Also i have some negative readings from the test with the false direction of the CT1.
Does anyone know how i can delete these readings, or where i can find info about deleting some selected data?