Problem after upgrading to bookworm - redis

I had been running emoncms successfully for several years and recently upgraded from buster to bookworm and 32 bit to 64 bit. I did a fresh install but migrated over my mariadb data and /var/www and /opt/emoncms and opt/openenergymonitor directories. I had problems with redis that I believe may have been down to permissions in that it kept crashing.

However, I now have issues where in the apache logs I keep seeing a bunch of lines with PHP warnings (an example below) and the website never pulls back feeds or inputs. If I disable redis it works fine.

[Thu Feb 22 22:13:50.232432 2024] [php:warn] [pid 13643] [client] PHP Warning:  Undefined array key "description" in /var/www/html/emoncms/Modules/input/input_model.php on line 373, referer:
[Thu Feb 22 22:13:50.232782 2024] [php:warn] [pid 13643] [client] PHP Warning:  Cannot modify header information - headers already sent by (output started at /var/www/html/emoncms/Modules/input/input_model.php:373) in /var/www/html/emoncms/index.php on line 316, referer:
[Thu Feb 22 22:13:50.235239 2024] [deflate:debug] [pid 13643] mod_deflate.c(869): [client] AH01384: Zlib: Compressed 12817 to 1249 : URL /emoncms/index.php, referer:
[Thu Feb 22 22:13:54.646102 2024] [mpm_prefork:notice] [pid 13641] AH00170: caught SIGWINCH, shutting down gracefully

before posting here, I decided to upgrade as I hadn’t upgraded in some time, that seemed to work ok using

Components: Emoncms Core v10.8.1 | App v2.1.6 | Dashboard v2.1.4 | Device v2.1.2 | Graph v2.1.1 | Backup v2.3.3 | Network v3.1.2 | Postprocess v2.4.7 | Sync v2.1.5 | Usefulscripts v2.3.11 | EmonScripts v1.7.10

Tbh, at this point I’d be willing to drop the data in the redis files, but I would want to keep my inputs and rule processing. I tried looking to see where the system knows what redis files to look for but couldn’t find it anywhere.
Any suggestions on how I get back to a working emoncms system?

Yes, we found previously that it didn’t work on 64bit. (I note the docs do not mention this though).

How did you install? Using the scripts?

REDIS is used more than just for the buffering of data IIRC - @TrystanLea .

I’d suggest starting again but stick to 32bit base OS.

Thanks for your comments. I did install a new version on one of my other pis that is still 32 but buster. I used a local redis but connected to mariadb and mosquito on the 64 bit bookworm. That actually worked ok.

I then cleaned up the /opt and /var/www directories on the 64 bit machine and used the file and the install scripts and it worked fine. I don’t know what the issue was previously, maybe just upgrading too old of a version?

I also copied the redis files from the backup and they were read without issue.

Seems all is happy now :grinning:. I am using an emonTX3, I have noticed with the new web code that it shows the type of feed files and time intervals. Probably my setup mistake but I have a mixture of time periods as well as variable. Think I need to read the forum to see what the differences are and what makes sense.