Community
OpenEnergyMonitor

Community

Possibly defective EmonTX V3

Tags: #<Tag:0x00007f6e02fbe858> #<Tag:0x00007f6e02fbe6f0> #<Tag:0x00007f6e02fbe600> #<Tag:0x00007f6e02fbe4e8>

Hi,
I recently bought an EmonTX V3 to add on to an EmonPi. I’m quite new to Energy monitoring so it may be a defective user and not a hardware issue.
I’m measuring various components of a heating system, outputs from wired in thermostats and programmers and outputs to motorised valves.
I seem to get a base reading on CT1 and CT3 doesn’t give any output at all. Ive tried changing sources for all the CT sensors and I’ve tried swapping the sensors in each jack too. Any help would be appreciated.

Does CT3 give a small but non-zero value, or a solid zero, or does it not appear in the emonPi at all?
Have you restarted the emonTx after plugging in CT3?
Does CT3 input not work with a CT that gives meaningful values when plugged in to a different input?

Hi Robert,
CT1 permanently gives a small value which increases when loaded.
CT3 gives a solid zero, no value at all. I’ve tried various different CT sensors in CT3 which have worked when plugged into different inputs and none have shown any value.
I’ve restarted both the TX and Emonpi over the last week or so since I installed the equipment.

How are you reading the output? Could you paste in the serial terminal window with the info after the unit has been restarted?

The CT sensors need to be connected before the unit is powered up (or restarted)

Do you mean the log from the Emonpi? if not, how do I access the serial terminal window?
The CT sensors were connected before restarting. Do you want me to paste in a recent section of log that shows the situation after restart?

I’ve been reading the output via the feed data viewer and via the feed graphs.

Any progress with this? Do you still have the problem, or has it been resolved?

No resolution yet. I was waiting for clarification of what the serial terminal window is. Its probably a straightforward answer. I still have CT3 with no signal at all and a constant base figure on CT1. I’ve just swapped them over to see if it stays the same CT1 to CT2 and CT3 to CT4. Apart from these bugs I have collected some useful data from the last week.

It sounds like you may have a faulty emonTx. We will send you a replacement tomorrow. Please let us know if it makes a difference.

We will include a USB to UART serial cable with the replacement emonTx, this will allow you to read the serial output direct from the emonTx. It plugs into the UART port on the rear of the unit, this will help with future debugging if needed. The baud rate is 115200.

Thats great, thanks Glyn. I’ll let you know how it goes.