Possibility of changing feed type from memory to mysql

Hello, I have been using emoncms for years and my database was created in 2010. I use a raspberry 4 on an ssd disk and therefore I have no writing problems.

The latest feeds created are of the MEMORY type, so with every restart (very rare but unfortunately it can be necessary) I lose the feed history.

Would it be possible to transform them into mysql by intervening directly on Mariadb via query?

Or, how should I operate to change the feed type? Thank you

Totally or just a few minutes gap?

Unfortunately total

Something not right with your setup then. It should be writing to a file and not holding it all in memory.

What is your setup? (base OS, how installed, how old etc).


1 Threads(s) | 4 Core(s) | 1 Sockets(s) | Cortex-A72 | 324.00MIPS |
Linux 5.10.63-v7l+
emoncmsServer2k21 | emoncmsServer2k21 | (
2023-05-22 15:56:26 CEST
15:56:26 up 19 days, 3:50, 1 user, load average: 0,21, 0,32, 0,50 HTTP

Apache/2.4.51 (Raspbian) HTTP/1.1 CGI/1.1 80


Host (
2023-05-22 15:56:26 (UTC 02:00‌​)
Uptime: 1674676 Threads: 25 Questions: 34775010 Slow queries: 3 Opens: 1156 Open tables: 1148 Queries per second avg: 20.765



Redis Server
PHP Redis

Powered by OpenEnergyMonitor.org | low-write 11.2.3


il problema riguarda solo i feed con indicato MEMORY , tutti gli altri con indicato MYSQL funzionano regolarmente

How did you install this? Clearly a non standard install.

How did you create those feeds?

The problem was introduced from version 11, before in the menu there was normal mysql, now only mysql memory.


So i checked mariadb, the feed exists as a table and is getting the values ​​regularly.

In the feed table I noticed that the engine field of the latest feeds has the value 8, while the old ones have the value 0.

Therefore I assume that by upgrading that value, the feed passes from memory to mysql without any problem.

You can confirm ?

Changing the number wont work alone.
You need to change the feed type on mysql itself or recreate it.
Memory feeds lose its data after a restart.

@TrystanLea will need to answer this one.

Hello @michelino It sounds like your settings.ini configuration may be hiding the MYSQL TimeSeries engine. What does the following entry look like for you?

engines_hidden = [6,10]