Community
OpenEnergyMonitor

Community

Positive offset on both solar production & home consumption

Hi - I’ve looked around for an answer to this but couldn’t find it. Thanks to helpers on here earlier in the week I’ve got an emonpi setup (using a raspberry pi v2 I had lying around plus a new emonPI shield and clip on CT sensors and voltage sensor from the shop). All seems to be working reasonably well - few wrinkles to work out. It’s a really fantastic piece of equipment. In the end I squeezed the CT sensor for PV inside the consumer unit. I’m on emonSD from oct2018 (only had a 8gb SD card to hand).

Overnight I noticed that PV production shows a minimum of around 25W (see image) and assumed this was probably interference on the CT due to being jammed in with other wires etc. However I was just investigating and have the Pi on my desk with the CT clamp attached but hanging free and it still registers around 25 to 30W. If I put it in port 1 or 2 I get pretty similar behaviour. Is this normal? I only have a few PV panels at the moment 680W so this will have a meaningful impact on my measurements (particularly on cumulative power since it’s present 24 hours a day). Note if I unplug the CT sensor the reading does drop to 0. Any ideas? Thanks!

Did you have the v.t. connected at the time? That can make a significant difference, because any noise etc getting into the ADC will, without the voltage, get rectified by the rms maths and added to the current, whereas if you have the voltage, current and voltage are multiplied together, so positive noise on one sample tends to cancel negative noise on the next.

25 W does seem a bit high if you do have the a.c. adapter. I’ve just set up an emonPi (but the Oct 2019 image, although I think the front end sketch hasn’t changed) and over just 10 minutes I have a low of -1 W and a high of 20 W, the mean is 9 W. That just on one input.

As it is, 25 W represents 100 mA in a c.t. rated for 100 A, so 25 W is 0.1% of the maximum reading.

The answer normally would be to that is to use a Raspberry OS image and EmonScripts. However this needs an update before it will work https://github.com/openenergymonitor/EmonScripts/issues/92 @TrystanLea. I was looking at the wrong merge - it is done.

Using the 2018 image is not a good idea long term as there are a number of issues with it that will come to light at some point.

Hi Robert - yep I’ve tried with the VT connected (and without) - the VT appears to work in that if I boot without it the VRMS value is set to 230, while if I boot with it I get a fluctuating value around the 235 mark).

For what it’s worth the reading of the constant 25W is actually quite stable - fluctuates by a few W but within the 23-28 range, so at least it’s consistent. The behaviour is essentially the same with either CT I have and on both inputs. One thing I have noticed - not sure if it’s relevant though - is that after plugging the CT into a power input it takes a couple of minutes to settle to the high constant value (when first plugged in there’s some big swings in measured power, then for a minute or so it actually looks good -measuring around 0 with some positive and negative values, but then slowly shifts up and stabilises around 25W).

I’ve no idea what to make of it - if it’s stable and additive I guess I could just adjust the code to subtract 25 from all readings (doesn’t sound very satisfactory though).

borpin: (sorry meant to get both replies into one post). I’ve just ordered up a 16gb card - should be with me tomorrow so I can try the 2019 emonSD. Though by the sounds of things that’s unlikely to have any effect on this issue? (the reset button on the HAT doesn’t do anything either - even if I hold it - is it likely to fix that?)

Try a shutdown, remove power (unplug Pi Supply), plug in.

That is correct as the VT needs to be there when power is applied (as opposed to a reboot). If not found on startup a default value of 230V is used. Adding the VT after powerup will never have any effect.

Attach all the CTs & VT before powering the Pi.

Yep no change. After a shutdown and power unplugged it just returns to the same state: VRMS is fine and totally plausible - 237 ish, power on the CT I have sitting on my desk is fixed at 23-25. (reset button doesn’t work).

Things I might investigate: updating emonSD to the latest, getting a different Pi (this one’s an old Pi 2 Model B Rev 1.1) - though I guess that’s unlikely to be the issue, potentially something wrong with the HAT?

I only tested mine for a few minutes last night, so I can’t comment about any drift or anything like that. And as I’ve said, there’s been no change to the front-end software that I’m aware of, so moving to the '19 version is not likely to affect this. The area that I would question next is the d.c. power supply - if that’s particularly noise, then it will affect the noise level seen by the inputs.

Thanks Robert - I don’t think it’s the DC supply as I’ve used two so far with very similar results (ones a fairly chunky one from an iPad, the other a smaller one built into an MK socket).

FYI here’s the trace for the last hour - it’s pretty stable but with a few ‘drops’ down to the true value of 0 (NB the CT is still hanging free on my desk at the moment).

I can try a third DC supply but suspect it won’t change much

I wouldn’t be too sure. See https://blog.openenergymonitor.org/2011/08/not-all-usb-power-supplies-are-created/

Try a different cable. Not all cables are equal!

Hmmm now this is interesting - too early to say it’s solved but…

You can see the point where I rebooted and started to use the power from a USB socket on the back of an Apple Monitor. I’ll keep an eye on it for awhile and see what happens. I’m really amazed though - the DC sources aren’t cheap ones really (one build into the socket might be I guess but the other one is an Apple 12W supply, you’d have thought it was moderately OK).

I’ll have a look to see if I can find another USB mini cable - don’t have many of those around though, they all seem to be micro these days

Did you get it from the shop? If so should be fine. Looks like the PS.

No I found in the draw where I keep lots of old cables! No idea where it came from. Does seem to point to to a problem with (both!) power supplies though - or possibly some sort of interaction with the cable.

No, but they’re intended for battery charging, not supplying an ADC measuring millivolt signals.

(The sums: 25 kW ≈ 1.1 V at the ADC input, 25 W ≈ 1.1 mV.)

So a bit of an update. With some interim conclusions.

  1. Having the VT connected makes a small difference as you’d expect but is not the cause of the problem.

  2. I’ve tried six different DC sources - 2 integrated into sockets made by MK and some other company, 2 iPad 12W apple chargers, 1 amazon branded one probably from a kindle, and one 5W iPhone apple charger. All behave identically and give a 25W base line power measurement (with VT connected) - without VT it jumps to more like 32W.

  3. The only DC source that doesn’t do that is using power from a monitor - which gives 3 to 4W (can’t remember if that was with VT or not now but either way it’s fine).

So it’s not a problem with a specific DC source - might be that all of them don’t have the necessary tolerances though I’m a bit surprised given that they behave so similarly.

What I’m going to do.
i) I’ve ordered a new mini USB cable (turns out I only have one)
ii) Might have to get a proper DC source - any ideas? I guess I should look in the shop.

Edit just to add: also tried powering it from a 5V chunky USB power bank. I assumed this should be a cleaner DC source without the high frequency ripple in AC>DC, the mean offset is slightly inproved 18W down from 25W but actually fluctuates more.

Just plugged a spare CT into both an emonTX and an emonPi, neither have a ‘special’ DC source (IKEA 3 way) nor a special cable and in neither case did it report anything when not connected.

@Robert.Wall, could it be the CT itself?

Most unlikely, I think.

1 Like

Have you used the header to move it well away from the Pi itself? Clutching at straws…