PlatformIO from a macbook air, COM port names

Hi Ive received boards and controller board, ive managed to program attiny boards ok but the controller board keeps failing. with the error:

Error: Please specify upload_port for environment or use global --upload-port option.

Its pre set in COM8 ive tried changing from 1 to 9 but it keeps failing. Anyone able to help with what im doing wrong?


Is the text green? If so, delete the ’ ; '(semi-colon), then change the com port number.
I found I needed to download the usb driver from the wemos website
Hope this helps

1 Like

The text was green i deleted the semi colon and it got further but still failed, i was trying to run the code from a macbook air im not sure if it would still be called COM1 or COM2 ect and i cant find it in the system info. I also probably think its a fake one i ordered it on ebay on a bit more research of them looks like version 1 of the D1 mini pro i also tried downloading a couple of USB drivers one from the wemos website and one from a link elsewhere that said it was for the V1. I have a genuine version 2 on the way from the Lolin shop so maybe ill have better luck with that. Thaks for your help!

Thats the problem, your COM ports won’t be called that - they will be something like “/dev/tty.usb”

Hi Jack

I use mac also.

Luckily it’s largely similar to Linux.

So whack open Terminal and type

ls /dev/tty.*

The list of external serial ports should show up. I always have a Bluetooth port show up, plus whatever USB adaptors connected.

P.s. PlatformIO should be auto detecting most of the time!

Hi Dan

thanks for the reply i tried as you said and unfortunatly still not turning up, ive tried installing two different USB serial drivers

the bluetooth one shows up /dev/tty.Bluetooth-Incoming-Port and lots like this /dev/ttyp1. By USB adapter do you mean i cant just plug the wemos board in directly? Yeah in platform io i just get the bluetooth one under devices the USBbasp works straight away for programming the other boards. The wemos board is slow flashing the blue LED when plugged in i notice theres a reset button on it which ive tried pressing and holding but doesnt seem to help.


I haven’t used Wemos specifically, but the ESP12 modules yes. I believe wemos has the usb-serial chip on it already so you can plug it in directly.
They have to be put into boot mode.
How are you doing this on the wemos?

Do you have a photo of the wemos you are using?

I am using this on my MBP:



Hi Jack, were you able to resolve this problem? I’m in the same situation trying to use Platform IO on a MAC for my diyBMS and could use some pointers. I’m on macOS Catalina 10.15.7 and can’t see any device under /dev/cu* I understand macOS has a native driver for the CH340x (at least used to include one…)



Does this article help?

Thanks Stuart, I tried this and unfortunately it didn’t help. Later versions of macOS are said to come with the driver natively, but not sure it’s still included in the latest release which I’m using. I’ve seen others on internet posting similar questions related to macOS Catalina.

Always worth checking the cable does data, some don’t.

Thanks I tried a bunch of different cables and actually found one which was power only. At the end I could not get the drivers to work in macOS Catalina and had to spin up the environment on a Windows 10 machine, and everything builds and loads like a charm :slight_smile:

Great, I’m getting rid of the need to install platformio in the next release, but you will still need working USB !!