Platform IO V5 "Upload file system image" option moved

Today I tried a third computer, without the wemos attached, still no “upload file system image” to be found.
Could it be that this is due to a change in code about 9 days ago? Or am I really doing something wrong? :wink:

Hi Maarten, the option should be there. Have you successfully compiled the code? Is the upload option there?

1 Like

Hi Stuart,

I have the uplouad option, but not upload filesystem image…

I do have some progress though…I updated the driver for my wemos d1 mini pro clone. It is on com4.
I change that in platformio, because it was on com3, then I hit upload and it said it was missing something from github, (sorry cant remeber wat is was… ;( ), I did that, and now, I get less errors.
I still do not have upload file system image, but now I could succesfulle clea, build and “upload”, accoording to platformio, with succes.

I havethe wemos, not on a controllerboard…waiting on the slow boat , but I can see its SSID and connect to it. But when I navigate to 192.168.4.1 it lotries to load “softap.htm” and gives error code 500, page not working.

Does it really need the controller board pcd and hardware to be able to display this?
I know i read in the main forum, you could hardcode the ssid and pasww but I cannot seem to find that post now…

The wemos definitly is a clone (i think 4mb) and I know it used to work with DiyBMSv3 code.
Have you got any ideas?

Thanks i anticipation
Maarten

When I first clean and then build it finds these errors though…


I dont know if that is of any help?

You don’t need the PCB for the controller web page to appear, but you do need the filesystem upload option.

Have you tried updating the platform Io core, it’s in one of the menu options.

Yes I have, but I did find:
platformio/contrib-pysite 2.37.191020 @ ~2.37.0 [Incompatible 2.39.201019]
Not sure what it means exactly though…

Ok, I am seriously flabbergasted…
I am sure I already updated everything and refreshed project tasks multiple times
But I did that one more, and now the tab “platform” and upload file system image " did finally appear,

got the right page, seemes to work now, thanks!

1 Like


Got it working all right, now to wait for the last parts :wink:

1 Like

Mine says that as well!

1 Like

I’m having the same problem now. No Upload File System image.
Everything is updated.
Had a brief issue with clicking on the platformio file under ESP Controller and having it open up the Attiny cell module section, only brief though

It finally appeared only after I uninstalled Live Share extension.
And now it’s gone again.

One with and one without. The without window was opened after the first. And the first only appeared after I uninstalled the Live Share extension.

If you can not find the option you can try running this command via a command prompt in the directory with platformio.ini: pio run --target uploadfs

I’ve had problems trying to upload the code onto the D1mini. The error I get is about some .py not being found.
I’ve used D1minis for a lot of other projects. Flashing them with a precompiled .bin file is much easier.
Would it be possible to make a .bin file available?
I’ll keep trying to get it uploaded through vscode and platformio.
Thanks for making this project Stuart. It’s exactly what I’ve been looking for.

If you are still struggling with compiling the code, I’ve started using GITHUB actions on the next release of the DIYBMS code. This provides a binary file automatically compiled and generated when code changes are made.

You can get the next version of the code from here. Take a look at the files DIYBMS-Compiled-Controller-ESP8266
and DIYBMS-Compiled-Module

You will need to program them to the chips using AVRDUDE (for ATTINY) and esptool.py for the ESP8266.

[Add code to reset mAh counter · stuartpittaway/[email protected] · GitHub]

Note that both the controller and modules will need flashing with this version of the code as there are LOTS of changes!

1 Like

Hi Stuart in the compiled controler folder have 2 files Both or only the filesystem image file have to be loaded ?
And in the case that both must be loaded, it is done with a single esptool command per file or the two files together. Could you (excuse my ignorance) share the loading message of the .bin files?

Additionally, the PCF78574 of the control module has address 0x20 (instead of 0x38) that can be configured in your software, is it possible to change it in the image?

Hello, you need to use both “upload” and “upload file system image” options in PlatformIO to program the ES8266, just as I showed in the YouTube videos I made (although the file system image button has now moved).

The PCF address can be changed, this has been discussed before…
[Error PCF8574 is NOT fitted, relay control not possible! V4.21 w/ attiny841-ssu]

All in order thank you very much Stuart for your generosity,

Hello,

my Name is Andy, I am from germany.
Need a little Help with my DiyBMS programming.

VS Code does not work for me, tried two different machines. on one, it wont install PlatformIO, on the other machine, it wont compile the source code, error (file not found)

But i could programm the controller and the cellmodules with the compiled files from Github (thanks Stuart) and the tools AvrDudue and the ESP Home Flasher, no problem

my qustion is about he Filesystemimage file.
where does I flash this to, to the Webmos Mini or the Controller itself.
Can someone give me a little but detailed advice.

Thanks a lot guys, you do a great Work

Greetings, Andy

Hello Andy, you don’t need to use platformio, follow the instructions here…

The code goes on the WEMOS MINI

Hy,

thanks Stuart for you Help and your amazing work!!!

I have already flashed the Webmos Mini with diybms_controller_firmware_espressif8266_esp8266_d1mini.bin

and i have already flasehed the Cellmodules with
module_fw_V421_attiny841_421_eF4_hD6_l62.hex

But what is about the " * diybms_controller_filesystemimage_espressif8266_esp8266_d1mini.bin"
Where does this file go? that is may question

thanks for your Help

Greetings Andy