Pi loses RF conectivity

I purchased a emonPi earlier this year. I connect to it a emontxshield to measure a 2nd solar array and a emontx2 to measure stored water temperature.
Recently it has started loosing connection to these modules. A quick reset of the Pi restores the connection but will quickly loose it again. I tried powering down the Pi for a couple of hours and the connection lasted 2+ days. Sampling from the on-board CT1 and CT2 continue unaffected.
Hardware or software fault? What is going on?

How recently? Have you recently updated the emonPi?

Inactive EmonTx

Emon TXs not updating after Emonpi update

No I haven’t updated anything. I should have said that it is running the standard 3rd May image

Can you provide emonhub.logs when it goes down again next? rebooting the emonpi will over write the logs as they are held in RAM so you should fetch them before rebooting.

Where are you noticing/confirming the loss of connection? I assume your dashboards are not updating, does the inputs page show the same "last updated " time for both units when they fail or do they go down at different times?

Have you looked at the emoncms or emonhub logs during a fault condition to confirm the connection is lost?

Your are correct, the dashboard does not update. Looking at the feeds both
appear to stall at the same time.
How do I get the logs out?

Forgive me here if I misguide, you but I don’t use an emonSD/emonPi myself, but as I understand it, only the latest update allows you to download the logs via the web page so you can either cut and paste from the “config” page of emoncms or ssh into the emonPi and view/download the logs from /var/log/emonhub/emonhub.log.

if you need pointers on ssh and finding the logs, I believe there is info in “the guide” eg SSH, lets us know if you need assistance with navigating the logs.

EDIT - I have just upgraded your user status to allow you to attach the log files, you will need to save them with a “.txt” extension as “.log” files are not permitted.

Sorry, this issue could have been caused by a recent firmware update. Please run emonpi update in local Emoncms (Setup > Admin > emonpiupdate) to pull in the fixed firmware (V2.8).

Forum discussion:

I updated the emonPi firmware ( now 2.8.1) and the fix appears to have solved the problems. It’s been up and running now for almost 4 days. No glitchs encounterd.
Well done.

Fantastic! Good to hear. Please keep us updated if you experience any drop

  • sent from my mobile device