PHPFina.php|post() padding max block size exeeded id=

I have some feeds that have stopped updating these are old devices probably not seen for a few months.

i see in this post a fix was done but no mention of what it was.

Below is a sample of the log file
running latest version of emoncms self hosted.

Thanks In Advance Dafydd

2016-10-01 10:40:49.297|WARN|PHPFina.php|post() padding max block size exeeded id=71, 1204667 dp
2016-10-01 10:40:49.308|WARN|PHPFina.php|post() padding max block size exeeded id=70, 1204667 dp
2016-10-01 10:40:55.169|WARN|PHPFina.php|post() padding max block size exeeded id=66, 1204668 dp
2016-10-01 10:40:55.187|WARN|PHPFina.php|post() padding max block size exeeded id=72, 1204668 dp
2016-10-01 10:40:55.191|WARN|PHPFina.php|post() padding max block size exeeded id=67, 1204668 dp
2016-10-01 10:40:55.198|WARN|PHPFina.php|post() padding max block size exeeded id=68, 1204668 dp
2016-10-01 10:40:55.205|WARN|PHPFina.php|post() padding max block size exeeded id=69, 1204668 dp
2016-10-01 10:40:55.213|WARN|PHPFina.php|post() padding max block size exeeded id=71, 1204668 dp
2016-10-01 10:40:55.219|WARN|PHPFina.php|post() padding max block size exeeded id=70, 1204668 dp

Any ideas on this anyone?> i have got more and more feeds that have not restarted after being off for a few moths.

Any Assistance greatly appreciated.

  • follow this at your own risk *

I’ve just booted up my emoncms install for the first time in a few months and had the same error.

Mine is now working, this is what I did to fix it.

Updated the Pi os with sudo apt-get update then sudo apt-get upgrade and rebooted.

I then tried to do a git clone and then a git pull of the emoncms directly. Neither of these worked. Clone gave an error that the directory existed and was not empty. Pull stated that there were files that had been edited.

Not being a git guru I downloaded the stable zip file from github. Unpacked it to a new folder. Selected all the files and folders that had been extracted and then copied / pasted over my /var/www/emoncms folder. Overwriting everything as it copied.

I then deleted the feeds that had errors and recreated them and they are now updating correctly. Though any historical data has been lost. For me that is not an issue, for others it might be!