Community
OpenEnergyMonitor

Community

Output Graphs?

(M G) #1

Needed to change units. Solved.

First off, great device!!

Question: With the local iotawatt graph application I am unable to see any output feeds anymore. I can see the output values fine in the status screen and they update there no problem. However, none of these show up as selectable feeds for graphing. All the inputs do and they graph perfectly.

Any ideas, or did something change for outputs?

Thanks

(Inactive) #2

Right. For anyone just tuning in, IoTaWatt outputs will only be selectable in graph if they have units = volts or watts. If it’s volts, it will appear under the voltage tab, if watts, it will appear under both power and energy tabs.

Yes, the API changed to use the names so that it can be used by other apps and to Support stored graphs (also relatively recent enhancement)

(M G) #3

Wondering if you could help with a new problem. When I go to the local iotawatt graph now no feeds at all show up for selection. Inputs or outputs. Is there any common cause that could result in this?

Attached screen capture of what I get.

(Inactive) #4

I’m working a similar problem with another user, so there may be a common cause. It looks like a bug in a library that I use, but I cannot be sure yet. Could you please enter the following URL in your browser and post the result?

http://iotawatt.local/feed/list.json

(Inactive) #5

Please see this issue:

If you have long names on your inputs and some outputs defined, this may be your problem as well.

(M G) #6

Thanks, I’ll see if that fixes it when released. Appreciate it!

(Jeff Noxon) #7

For what it’s worth, I ran into this problem today. I was able to make it work again by shortening the names of a few inputs. I have 14 CT’s attached and a bunch of outputs defined.

When I fetched /feed/list.json, it was invalid json (truncated), so I assume a buffer somewhere needs to be larger.

I’m running 02_02_30.