Community
OpenEnergyMonitor

Community

OpenEVSE WiFi AP not broadcasting

Tags: #<Tag:0x00007fdb5d95c7f8>

I’ve just received my 7kW OpenEVSE charger. I have powered it up - no charger cable, just bench testing. Should the WiFi module fire up the AP in this state? I have tried holding down the reset and flash buttons but the AP does not appear.

Are there any specific steps needed - I looked at the firmware code and from what I could see it doesn’t seem to have any specific conditions for starting the AP?

Thank you.

Hi Steven,

The Wifi module should start up in AP mode. Is the module getting power? Does the LED on the module flash when you power it up and when you hit the rest?

If the WiFi module it connected correctly it should print “OpenEVSE WiFi” to the LCD at startup then the AP IP address. If you post some photos I can try and check the wiring?

Hi Glyn,

I checked all of those things first - I bought the fully assembled kit, so it is wired up correctly. I then tried just connecting the module to a USBtoTTL programmer and viewed the output on a serial monitor. Unfortunately, it just seems to be stuck in a reset cycle - specifically it boots up and then a few seconds later the wdt_timer resets it. The red and blue LEDs flash every 7 seconds in time to this behaviour. This explains the lack of AP.

I then grabbed the github code, set it to debug and flashed a Wemos D1 mini and connected that to the serial monitor. It worked first time and the AP was visible. So I have an issue here.

I bought a ready made kit that should work and I can only conclude that it was not tested, as this is the most basic check for the WiFi module. I need to install this kit for a client, so I don’t want to have to deal with fixing the WiFi myself. How best to get a working WiFi module replacement?

And could you tell me what version of the firmware would be on the WiFi module? I assume it is one of these releases

Thank you.

Do you have an OpenEVSE or EmonEVSE?

Yes, it will be one of these releases https://github.com/OpenEVSE/ESP8266_WiFi_v2.x/releases

It therefore sounds like a hardware issue. We will send you a replacement Wi-Fi module. Please contact shop support and quote your order number to arrange replacement [email protected]

Apologies for the hassle.

Thanks for the prompt response. I have to the emonEVSE. I’ll email the details through.

I replied on the ticket. The replacement module shows an AP, but I cannot connect to it. It drops off before I can connect to it. I’ve tried a couple of different mobile phones to be sure.

What could the problem be?

This is very strange, that module was tested extensively before shipping. What exactly is the failure mode? What message does your smartphone display when you try and connect? Does the captive portal page load? Have you tired turning off mobile data on your smartphone?

I’ve just seen your support ticket regarding V2.8.1 not working but loading the latest mater branched fixed the issue? That’s very strange since the latest master branch is the same as V2.8.1. Pleae could you confirm.

Yes, exactly that. How exactly is the release version built? When I grab the master branch and flash the ESP module it displays BUILD_TAG on the LCD screen, whereas the release binary displays 2.8.1.

Here is a video of the start up sequence and the AP behaviour. Note after I attempt to login, the AP disappears and it never appears again. The LCD alternates between the Firmware version display and the SSID/PWD display.

Here is a video with both 2.8.1 and master branch behaviour.

Interesting, thanks a lot for the videos. I can see the issue, I have not experienced this before. It looks like the firmware was not correctly loaded in the factory. I appologies for this.

The FW is built using platformIO, the build version comes from the version set in platfromio.ini. e.g https://github.com/OpenEVSE/ESP8266_WiFi_v2.x/blob/master/platformio.ini#L33

How did you compile and upload from the master branch?

I use Platform IO with this ini file:

[env:huzzah]
platform = espressif8266
board = huzzah
framework = arduino
upload_port = COM17
monitor_speed = 115200
lib_deps=
ESP Async WebServer
ESPAsyncTCP
PubSubClient

If you run $ pio run -t upload when in the project directory of ESP8266_WiFi_v2 then you will upload using the standard platfromio.ino file which will include the build version.

Thank you Glyn. I’ll do some investigation. I did notice that the platform.ini file for the build does build settings that specify a higher upload speed - maybe this can cause a problem with the updating of the firmware. As I can at least work around the module issue by building and flashing it myself, I should be OK to get by for now.

I’ll report back if I can either replicate the build and upload issue or if I can figure out why the AP is not staying connected.

1 Like