Community
OpenEnergyMonitor

OpenEnergyMonitor Community

OpenEVSE not connected to MQTT - intermittent

Tags: #<Tag:0x00007fc0acb293e0>

Occasionally my OpenEVSE stops communicating over mqtt to my emonpi - every single other device which sends or receives data fro the hub is working fine but the OpenEVSE webpage says it isn’t connected, the feeds on the emonpi haven’t been updated for 19 hours and yet it refuses to connected despite restarting the WiFi on the device. Nothing relevant in the mosquitto log.

I’m using the 3.1.1 firmware but it has happened with the earlier firmware and also the older wireless module. Physically resetting the entire thing via the breaker will solve it but that presumably shouldn’;t be necessary.

Hi Nick,

Sorry to hear your having issues. This sounds like a WiFi connectivity issue. What is the WiFi RSSI value shown on the System tab of the OpenEVSE interface?

I’m running 3.3.1 with RSSI of -70 and I’ve not been able to replicate any connectivity issues.

Maybe improving the strength of the WiFi signal may help?

-86, but I have four wi-fi routers so I can’t control which it connects to as it doesn’t allow select by BSSID

I think this could be the issue, the module it’s probably hopping between the different routes. Could you try setting up a dedicated access point for it ?

I’ve created another SSID on the closest router and the rssi is down to -74 and it is currently connected.

Hopefully this will resolve it.

1 Like

This is the same problem I was seeing with our WIFI, it seemed like once it had connect it alway tried to connect to the same wifi mac address. the only way to fix was create its own SSID and broadcast on that AP. I have now changed to an ethernet version and all problems have gone

At the risk of this getting boring, I’ll say it again, the WiFi on ESP8266 devices is not robust. I have tried many and the only implementation I have confidence in is Tasmota (yes I know in theory they all use the same core libraries). There are multiple instances of difficulty with ESP8266 based WiFi connections on this forum.

1 Like