OpenEVSE not charging - help!

Just got back from a weekend away and need to charge the car now (rather than overnight as usual) and it is failing to do so.

It starts to charge on manual override and then stops - the cycle keeps repeating with the contactor dropping the connection about 10s into full 32A.

Any ideas? Any diags available? Can’t see any errors on the web interface.

I really need get it charge and only about 20 miles left. Help!

As an update, I tried again an hour later after unplugging and reconnecting etc. and it worked.

No idea why - guess it could be either the car or the charger but without any errors or diags available, I’m none the wiser.

If there is something I can look at to debug if/when it happens again, please post the details here.


as you say with no other info it is back to basics, ensure all the cable connectors are good and tight including the sensor wire connected to the control module. Also check the incoming power cables both in the EVSE and also on the feed contactor.


Worryingly the car (MG5) stopped charging after 20 minutes last night on a timed charge (which matches the Octopus Go cheap period). Fortunately I wasn’t going anywhere today and it has currently been charging fine for nearly three hours on manual override. If I can’t depend on an unattended overnight charge completing I’m going to be in a serious bit of bother.

Never had any issues before and have had the charger for nearly 18 months now. The other EV we have (Zoe) will be charged tonight on timed so we’ll see what happens then.

Would be useful to know if there are any diags or logging I can enable.

Hi Nick,

We’ve not really come across temperamental charging like this before. What state does the EVSE it enter when charging stops? Are you logging the EVSE state to Emoncms?

Since it was working fine previously, the first thing I would check is to inspect the EV connector, EV cable and connections in the EVSE. Look for any water ingress or corrosion on the EV connector and check all the connections are nice and tight inside the EVSE, obviously be sure to isolate before opening or consult an electrician if in doubt.

Well after my MG5 failing to charge at the start of the weekend but managing a whole four hours on timed over Sunday night, the hitherto faultless Zoe also had issues last night, only charging on and off for about two hours.

I’ll open up the unit today and take a look as the problem clearly isn’t with the cars. The tethered cable looks OK and I even sprayed some contact cleaner into the plug just in case but I guess that isn’t it.

I should be logging all the feeds; what am I looking for specifically?

Some screenshots from the web interface are below.

From the history it seems to cycle between charging and EV connected numerous times when usually it would start charging at 00:30 and stop at either 04:30 or when the Zoe is full (which would probably be about 04:00 this time of year). A full charge to the Zoe overnight is usually circa 25kWh but it only managed 15kWh last night and wasn’t at 100% this morning.

No sure what logged value I should be looking at but the ev_state moves from 254 to 2 when the timed charge starts at 00:30, then up to 3 when I assume it is charging and then you can see it moves up and down between 3 and 2 (which match the changes in charging and not charging).

The switch to/from is based on the voltage of the pilot signal, so that would probably be a good thing to check.

I am fairly sure you can check this with a multi-meter in AC voltage mode. In state C (3) the voltage between the pilot high/low should be 8V AC, if it is closer to 9.5V AC then it could be miss-read as state B (2).

I checked inside the unit and all dry with tight connections - I unscrewed the pilot and CP and reseated just in case.

However I have noticed that something appears to have been chewing the cable - lots of small teeth indents over about a metre of the cable near the car end i.e. where it lies on the ground. I’m suspecting that maybe one of the wires has been compromised or water has got in although I can’t actually see anything as the puncture marks are so small. Not sure how that would increase the voltage though to move state from charging to not charging - would have thought it’d be the other way around.

Anyway, looking to see if I can shorten the cable (it is 10m but 5m will do) at the car end - is it easy to take off the plug and reconnect? If not, I’ll have to buy a new cable and see if that fixes the problem.

I took the plug cover off to see if it seems easy to shorten the wire - the conclusion I came to is that it isn’t.

More worryingly, there was moisture inside the plug (it is stored in the wall holder under a cover) and most concerning is that it appears the outer cable has never been clamped - the clamp screws are tightened down and the outer cable finishes half-way up the rubber gland as shown in the photo below!

Wish I hadn’t seen that as now nervous about using it at all and there isn’t room in the plug to move it up - the exposed wires would need to be shortened. If I buy a new one, can you check it isn’t in the same state?

If you do replace I got my cable from these people and it seems good so far


The Zoe got home and tried to charge and the state is moving from Waiting - Not Connected, Waiting - EV Connected and EV Connected but failing to go into charge.

Looks like we’re going to have to find an alternate method of charging.

A new 5m cable arrived today (courtesy of Rolec - and it has the cable clamped in the plug correctly, I’ve checked!).

Fitted and a quick 5 minute charge went OK so we’ll see if the Zoe completes a full four hours timed tonight and if so, it’ll be the MG5 on tomorrow night. If not, I guess the unit itself is toast and I’ll have to see if it can be repaired or I replace it with something else.

The new cable didn’t have a PP wire in it so that’s clearly now unconnected. Not sure if it will cause an issue - don’t see any errors flagged up in the diagnostics on the unit, car knows it is connected and so does the unit.

Anyone know if I need to worry about that or need to do something?

[Edit - I assume if the PP is an issue, I can just put a 220 Ohm resistor between the connection in the unit and earth to correctly identify the tethered cable is 6mm/32A]

To close this, replacing the cable has resolved the charging issues.

I’ve no idea if the problem was due to the exterior sheathing at the plug being short (with consequently no strain relief for the inner cables nor a full seal with the grommet and the subsequent wetness inside the plug) or the weird tiny bite marks on a section of the cable. Possibly a combination of both.

It might be advisable to check your plugs just in case.

To answer my own question regarding the PP wire, it was cut short and hence floating/unconnected at the plug end of the original cable and therefore replacement with a 3.1 cable rather than 3.2 is perfectly fine in a tethered situation.


Great to hear, nice work getting it sorted :+1: