OpenEVSE new user interface, testers & translations needed

The New interface looks great. Just an idea for a modification.

My usage case is sometime the car is parked at home for a few days and it would be nice if they was a way to only charge from solar and not over night. but leave the timer in place for the nights when I need a full charge for the morning. I have tried enable change in eco mode but that just goes straight to 32A.

Paul

1 Like

I guess best way would be to have a way to disable the scheduler ain’t it?

@Guillaume_S

This would be a good feature for me too, and I suspect many others :slight_smile:

John

I was running the latest dev build for a while, and when eco mode is selected the timers are ignored. I liked that change.

Had to revert as the shaper wasn’t working for me unfortunately.

What problem did you get with the shaper?
Can you post your config?

Basically the shaper was ignored, Ive toggled it on and off, Changed the value, there is no difference.
Almost as if it doesnt “see” what the openevse is using. I use it to limit the charge so i dont go past what the house batteries will output. It charged the car at the full speed.

My EVSE, is running 7.1.3.T2 and a huzzah esp32.

I have my dad’s still running the same dev build. haven’t reverted his yet, (openevse wifi v1)
Ran a test and its made a liar out of me. worked as expected. Gonna have a poke at mine now.

Ok, There is something weird going on,

Works perfectly on dads, openevse wifi v1 build.

On my huzzah one, it doesnt. (For reference when on batteries i feed it a falsely high value, I am not currently pulling18kw!, just offset by about 10kw)

I let it run for a few minutes, and there was no throttling even though it was above the load limit, changing it down. Any clues?

Edit: Reverterd back to the prerelease build (may 10) and works as expected.

I think that’s the best way, maybe another button on the main screen for eco only

Just installed 5.0.0 Master. I can no longer change the charge current using the slider when manually charging. This has always worked fine previously. Also tried the 26/9 dev release and same problem. I can set the max in the OEVSE screen but cannot move the slider on the charge page.

Ah! It has just started working after about an hour since installing 5.0.0. I am thinking a Cookie or some cache effect. All okay now!

1 Like

After three days, the connection to the MQTT server has stopped, saying “no connection”. Disabling and re-enabling makes no difference. Nothing wrong with my server. Restarting the OEVSE WiFi via the menu in the firmware section fixes the problem.
I had this identical problem months ago with a much earlier version.
I am using the latest 5.0.0 DEV version. master_8c9a482c_modified
But I think the problem has been there for some time.
Does it continually retry?

MQTT connection stopped working again. Disable and enable make no difference. Rebooting WiFi code makes it work again. I’m going back from the dev to the 5.0.0 release

11 days now with 5.0.0 and zero MQTT issues.

I spoke too soon. It happened again this morning and I had to reboot the WiFi code. This is with 5.0.0

Happened again today. As usual, had to restart the WiFi code.

Did the toggle of the eco mode ever get added? would be really useful now we are getting to the summer again.

I don’t think the history page is too spammy. I just think it’s not very good in describing what is happening. For example if it is on a timer and is in disabled state, when you plug the ev in, it just reports as being disabled, while in fact it is an action of the the vehicle is connected. There is this weird thing of repeating the kwh when not necessary though.