Community
OpenEnergyMonitor

OpenEnergyMonitor Community

OpenEVSE Eco mode Minimum charge time

Tags: #<Tag:0x00007f1d4ec133c0>

Hi,
I observed that the “Minimum charge time” settings in Eco mode, doesn’t want to work for me (default 600 sec.) on OpenEvse 3.3.2 - 7.0.2EU + EmonPi.
Every “Consumption” spike, above “Solar production”, longer than 30-60sec, will trigger “Waiting for solar” ( => relay OFF).

This will not work great with a running electric /oven/iron/espresso-machine, which start/stop every minute.

Do you have any issues with this setting?

Interesting, thanks for reporting this. Could you paste the output of http://openevse-xxx/config so I can check our config? Replace xxx with your openevse ID

Yes.
Here it is:
{"firmware":"7.0.2.EU","protocol":"5.1.3","espflash":4194304,"version":"3.3.2","diodet":0,"gfcit":0,"groundt":0,"relayt":0,"ventt":0,"tempt":0,"service":2,"scale":220,"offset":0,"mqtt_supported_protocols":["mqtt","mqtts"],"http_supported_protocols":["http","https"],"ssid":"Home1_EXT","pass":"_DUMMY_PASSWORD","www_username":"","www_password":"","hostname":"openevse-3054","sntp_hostname":"pool.ntp.org","time_zone":"Europe/Bucharest|EET-2EEST,M3.5.0/3,M10.5.0/4","emoncms_server":"http://192.168.0.171","emoncms_node":"openevse","emoncms_apikey":"_DUMMY_PASSWORD","emoncms_fingerprint":"","mqtt_server":"192.168.0.171","mqtt_port":1883,"mqtt_topic":"openevse","mqtt_user":"emonpi","mqtt_pass":"_DUMMY_PASSWORD","mqtt_solar":"","mqtt_grid_ie":"emon/emonpi/power1","mqtt_vrms":"emon/emonpi/vrms","mqtt_announce_topic":"openevse/announce/3054","ohm":"","divert_PV_ratio":1,"divert_attack_smoothing_factor":0.4,"divert_decay_smoothing_factor":0.05,"divert_min_charge_time":600,"tesla_username":"","tesla_password":"","tesla_vehidx":-1,"flags":1547,"emoncms_enabled":true,"mqtt_enabled":true,"mqtt_reject_unauthorized":true,"ohm_enabled":false,"sntp_enabled":true,"tesla_enabled":false,"divert_enabled":true,"pause_uses_disabled":false,"mqtt_protocol":"mqtt","charge_mode":"eco"}

Mmm your config all looks correct

In this condition that is not the min charge time that would apply, the minimum change time starts when the charging starts and ensures that the charge does not stop within the that first 600 seconds (10 mins) as the charge session is going on for longer than 10 mins then the charge will stop when demand goes under the 6A threshold.

I assume you are setup using grid I/E? That graph is very hard to read but I think it is what I would expect to happen. After the min timer has expired there is a rolling average (kindof) that is used to make the decision to stop charging. The attack/decay can be used to tweak these so it takes a longer/shorter time to switch on/off. The default values should start the charge quickly but be slow to stop. That being said it does look like there is quite a large delay to start again…

It would be clearer to compare the pilot to the grid IE feeds.

Thanks for the explanation.
Yes, I use grid I/E.
Any idea, for an approx. value of attack/decay, to obtain a 10-15min “delay”, when “export” drops (“use” rises)?
Here is the moment when OpenEvse detected, high enough “export” values and started the charging then dropped later.

Charging during this day:


There is a constant ~400W export, is there a way to lower this value?
I want to export as low as possible when charging the car.

Is it possible to add a “checkbox” - enable/disable, which can keep a minimum of 6A charge rate in Eco mode?
This should solve any random consumption spike issue (when the relay turns OFF) and any interruption of the balancing procedure on a car battery at the end of charge and no need to modify attack/decay values, which is better to be fast.

It is hard to tell from those graphs what the issue might be, really I would need to see the Grid I/E feed and the pilot and maybe the charge_power.

Kind of the whole point of the divert is to match the charge rate to the available power, part of that is to turn the relay off under conditions when there is no longer sufficient power either because of other consumers or lack of generation.

If you do not want consumers to effect the car charging then you can use the solar fees as the input rather than Grid I/E. In its default configuration the OpenEVSE tries to not import any electricity while still trying to be relatively kind on the relay. making the decay value smaller will increase the time before the relay switches off, also decreasing the PV power ratio will increase the charge rate so more of the solar is used, see the original PR

2 Likes

Today, in the morning, I started the charging with default “Solar PV divert” values.
After 10 minutes the charging was stopped (AirC rumped up), so I adjusted the PV ratio to 0.2, Decay to 0.02 and Minimum charge time to 1000sec.
This solved the issues about “random spikes” turning off the relay too quickly.

Here, from 9:30 to 11:00 I was on a trip.

Divert = Charging

Keeping Export low as possible during charging (80-200W):

Thank you for your help! :slight_smile:

1 Like