OpenEVSE doesn't change status or hangs when disconnecting EV


I have a brand new OPENEVSE charger (OpenEVSE WiFi EV Charging Station 7kW | European KIT).
Ordered January 2023. Assembled, then tested with an EV simulator as explained in the assembly and test guides.
FW versions are as follow (didn’t update them) :
OpenEVSE : 8.2.2.EU
OpenEVSE WiFi : 4.1.7

Wifi connection is ok, I could then configure it (max 16A).

Problem is : when disconnecting EV

  1. Sometimes everything goes well : controller sees disconection and updates its status
  2. Sometimes controller seems to crash (totally unresponsive, even with physical button : Web GUI still works, but displays error message “OpenEVSE not responsive or not connected”)
  3. Sometimes controller is still responsive, but controller seems stuck with status “EV connected”

Only way I found to get it alive again is to power cycle its main supply.
I tried reseting to factory config and setting a minimal config : only wifi / timezone and max current : Same situation.

Anybody can help, as this EVSE is brand new and tested ?


Hello again,

Another strange fact :
Apparently my car has been charged correctly tonight.
But I saw this strange status this morning (on the web GUI) :

Warning!! Not all the safety tests are enabled, please take extra care before charging your vehicle.
Test Status
GFCI Self Test: Disabled
Ground Monitoring: Disabled
Stuck Contact Detection Enabled
Temperature Monitoring: Disabled
Diode Check: Enabled
Vent Required: Enabled
Error Count
GFCI: -9568
No Ground: -9568
Stuck Contact -9568

Some self-test are disabled, and I have no idea why.
Yesterday, Diode check was disabled.

Behavior seems really strange…

Thanks for any help.

Another strange status today with some errors and a self test disabled…
Restarting the firmware clears the errors… until it appears again.

Really need help please !

Hi Serge,

Could you post some photos of your build, so we can check the connections?

What EV are you charging and what cable are you using?


Please find the requested build photos at the bottom of this post.

Car is a Volvo XC40 PHEV, model 2019 or 2020.
It can charge up to 16 A, single phase and has 10 kWh battery.

Cable from charger to car has been ordered together with the charger on your online shop.
Cable from electric box to charger is 3 x 2.5 mm2.
I measured resistance of protection earth from another plug in the garage to the chager’s back aluminium panel or to the metal button, it is < 1 ohm.

After taking photos, I switched on again power and got this error :

After a new power cycle, it was ok…

Also, please note that in my support request #10876 (January, 23th) I noticed and informed you about the fact that controller PCB assembly did have problems. I sent you pictures. Maybe PCB had other problems that I didn’t notice ?

Thanks for your help.

Photos of assembly :

Thanks for the photos. You’ve done a tidy job with the installation. The only thing I should mention is that stranded cable should have bootlace ferrules. It will probably be fine at 16A because the thermal effect will be low, but it’s still good practice:

See step 4 of the build guide: OpenEVSE Kit Build Guide — OpenEnergyMonitor 0.0.1 documentation

However, I can see any issue which may be causing the ‘lock up’ issue that you describe. This is a very strange issue that I’ve not come across before. Are you still experiencing this issue? Does it happen at the end of every charging session? Or does it sometimes happen randomly?

Can you check the voltage of the 5V and 12V rails on the OpenEVSE controller? The only thing I can think of is a possibly faulty power supply could be causing the controller to ‘brown out’


Thanks for your reply.

Regarding 16A connections, I did follow the build guide :
-For input supply, blue and brown wires on the left are solid wires.
-Output blue and brown wires (on the right, to EV) belong to the ordered EV cable and are stranded. I did crimp ferrules on them. This is simply not visible on the pictures, as ferrules do not have visible plastic insulation (only metal cylinder inside the relay’s screw connector).

I tried fastening again screws and connections. Also verifying connectors and plugging them in again.

Problem is still happening randomly. Not necessarily at the end of every charge session. In fact, I don’t really know if the problem occurs at the end of the charging session. I only notice it when I take my car, or next time when I try to put it in charge again.

I will verify controller’s DC supplies with an oscilloscope.
Could you please tell me where to find HW doc of the controller board?

Also, let me please insist on the fact that controller had assembly problems, out of the box, when I received it. I did report it, with photos, through support request #10876 (January, 23th) : a tantalum capacitor on the bottom side wasn’t properly soldered.
It might be that the controller has other problems and/or is faulty ?

Thanks in advance for your help.

Best regards.

I think you can find the schematic and gerber files here: OpenEVSE_PLUS/OpenEVSE_PLUS_v5.5 at master · OpenEVSE/OpenEVSE_PLUS · GitHub


Here are measures of +5 V and +12 V supplies.
Measures made on JST6 connector. With a DMM in DC mode, and an oscilloscope in AC mode.
For oscilloscope’s screenshot :
CH1 : +5V
CH2 : +12 V

  • EV not connected
    DMM :
    4.73 V
    11.81 V

-EV connected, not charging
4.75 V
11.81 V

-EV Connected, charging @ 16 A :
4.66 V
11.81 V

Is 5V supply normal ? (seems to have problems : Falls to 4.66 V and always has ripple).
Ripple might come from wifi module ? Is it supplied with +12V or +5V ?

Thanks for any help !

I’ve measured 4.9V and 12.07V on a working test unit. Your readings sound fine

The only thing I can suggest is that we send you a replacement controller for you to test. I’ve never come across a controller which freezes before. Maybe it’s an issue with the firmware. Once you’re up and running with the new controller could you send us the old controller for testing? I’ll message you via the support ticket system to arrange a replacement.


Thanks for you proposal.
Behavior shouldn’t be worse with a new controller ! Anyway, its PCB had assembly problems…

Some ideas that I can see… could this stranges error states be influenced by :

-Temperature ? It seems error states appear less frequently now, with temperatures > 0°C (my garage isn’t closed with doors, the EV charger is at outside temperature)

-Wifi signal strength ? RSSI indicates -80 to -85 dBm, which is very low. Maybe forcing higher power TX, thus causing supply disturbance ?

Thanks !


Maybe that could help understand the issue :

OpenEVSE status this morning :

All fields of the web GUI either unpopulated or with zero values… But it did charge during the night.

And then, this afternoon, up and normal again (and I did not restart or power cycle it…)

OpenEVSE controller : Firmware: 8.2.2.EU
OpenEVSE WiFi : Firmware 4.1.7

Thanks !


Maybe this can help identify the problem hapenning on my openevse charger :

I had again errors this morning (see screenshot).
From the web GUI, restarting openevse controller did not reset the error.
Restarting the ESP32 wifi did reset it.


It sounds like your controller is faulty, we’ve sent you a replacement last week. Please let us know how you get on.


New controller is in service since March 31st.
Unfortunately, I had an error state again last night. Exactly the same as before. As if these strange values were not random (5x GFCI and 6x no ground errors).
Again, restarting wifi firmware cleared it.
Car has been charged, was full this morning.

Thanks for any help.

Also sensor scale and offset values seems suspicious. ( Coincidentally same as your GFCI no ground values )


New controller is in service, and I also updated wifi FW as suggested by support.
FW versions are as follow :
OpenEVSE : 8.2.2.EU (unchanged)
OpenEVSE Wifi GUI v2 : master_3a05c6ad

New wifi FW, but still the same strange errors…
And as noticed by @Guillaume_S , sensor scale and offset values seems suspicious (coincidentally same as your GFCI no ground values).

See pictures below.

Thanks for your help.