OpenEVSE Controller Nodemcu Connection

Hi! I just receive my emonevse V5.5 board and I try to connect her to a Nodemcu using firmware “adafruit huzzah32.bin” (v5) and pinout tx/rx without success ; I have tried other module (D1 mini esp32) and other firmware (“Nodemcu esp32.bin”) with other pinout (16/17) but it doesn’t work anymore and I have no connection with emonevse board. Maybe I think there is probleme with the board…

thanks for your help

Can you post the output from the Debug console and OpenEVSE console under settings > Developer

hi, this the screen shot openevse and debug consoles with emoneve 8.2.3 and adafruit huzzah32 V5 :

@glyn.hudson it’s possible to test open_evse module with an usb_asp and a software on serial ? Maybe i can try ping on tx/rx with usb ttl?

Yes, you can connect to OpenEVSE controller via serial

After check the serial, i find the problem : it was the power supply! I used an ESP32 D1 mini and when he was connected on my imac, connection with open_evse board was ok but not when he was connected on my macbook pro (i don’t understand why because it’s same voltage and amps…) so i had connected my D1 mini directly on the openevse board (out 5v) without DC/DC converter and it’s work!

Now i have another problem coz my amperemeter doesn’t send data and open_evse say that power is 0 when the car is charging… i try to set it with “$SA 1” in RAPI command but without sucess → NK^21; the tore measurement is ok maybe should i used html command but i don’t know how to do.

What open-evse controller FW are you running?

Could you share a photo showing how you have the CTs connected?

I use D1 mini 32 with FW V5 “adafruit huzzah32” but i have the same problem with 4.2.2 (huzzah32)

Sorry i have sent the wrong screen-shot! This is Ct connection :

I have tried to change the way and with differents resistior (47, 22 and 10 ohms) but nothing…

I don’t recognise that sensor, what CT are you using? It should look like this?

You should have either the Line or Neutral cable threaded through the CT, not both.

What’s your order number? I’ll check what components you should have.

It’s 50A Ct but not an orignal ; I have a OPENEVSE V5.5 board with T2 socket (non-tethered), i have no GFCI coz i have a RCBO B type for protect my installation.

At the beginning, all worked well (during more one month), but i have decided to change my D1 mini esp32 with FW V5 adafruit huzzah32 for an nodemcu 32S with FW V5 nodemcu32s. But this last FW didn’t work and i am return to the first configuration with the D1 mini.

Since, i have no power measurement… to solve the problem, i have reinstalled emoneve 8.2.3 after reset and FW gateway, donegrade to 8.2.2 and FW 4.2.2 to use RAPI commands, test my Ct with multimeter, test open_evse board with different resistors but it’s useless an i don’t know why i haven’t power measurement on the interface…

Hi, i have replaced the ct sensor, flashed my openevse board and change my gateway for a WT32 but i have alway 0 power when the car is charging… any solution plz?