Community
OpenEnergyMonitor

OpenEnergyMonitor Community

openEVSE Charger – Safety Warning

@glyn.hudson

I’ve a single phase charger built from a kit to which I added the latest Wifi card a couple of months ago. It’s been running fine until a couple of weeks ago.

On 2 or 3 occasions the openEVSE webpage gave a Safety Warning, openEVSE appeared to be frozen (tho’ the webpage responded when refreshed) but the powered by version showed 0.0.0. The following 4 screenshots give the full picture:

Screenshot (311)



Screenshot (314)

My solution has been to try enabling the Safety Warnings but as this did not work then to press buttons, issue RAPI commands and try updating both firmwares. This never solved the problem but after time 1hr+ the Safety Warning would go away seemly of its own accord.

Until yesterday (Weds) I had not documented things:

The EV (Tesla) charged overnight under Demand Shaper SMART control. The EV remained connected throughout the day (Weds). A couple of times thru’ the day I checked the webpages for Demand Shaper and openEVSE – all as expected OK with openEVSE showing WAITING because ECO mode was set.

Then at 5pm I noticed the Safety Warning had appeared but decided to take no action but to see what happened.

At 8:15pm a cron script ran. Its function to check if the EV is connected and if not to send an advisory text message – this script has been working for weeks.

The script first checks the openEVSE state and if 254 (sleeping) a $FE enable is sent followed by a $FR reset. As the EV was connected, charging then started and ran for a short while until target_soc was reached. This is an annoying behaviour but a separate issue as is the amount of time openEVSE is in 254 – see screenshot – just 5mins in state 2 after the charging stopped then back to 254.

Before going to bed late, with the Safety Warning still showing I ran @TrystanLea’s latest script to correctly set up Demand Shaper SMART which it did – just 7 mins of charge to happen (but it had charged fully earlier in the evening).

Lo & behold – the Safety Warning had disappeared – situation back to normal.

A coincidence? If not - why should/how could Demand Shaper SMART affect openEVSE in this way?

I believe Demand Shaper updates its Agile forward tariff info in the PM and I first noticed the Safety Warning at 5pm – am I clutching at straws?

Would very much welcome yr suggestions - thx

@glyn.hudson

By way of update …

The EV has been connected all day.

Until just after 4pm everything was normal – openEVSE WAITING in Sleeping state 254. But then the Safety Warning appeared.

Just after 5pm I ran @TrystanLea’s latest script to correctly set up Demand Shaper SMART but that did NOT change things.

openEVSE would not respond to RAPI $FD disable.

I turned Demand Shaper from SMART to OFF – no change.

Then to ON – charging started but the Safety Warning remained.

Then to OFF but charging continued until the EV was fully charged. openEVSE then switched to WAITING but the Safety Warning remained.

At 6:30pm the Safety Warning disappeared of its own accord – no intervention by me.

The ev-state was 254 throughout except switching to 3 whilst charging then to 2 for approx 5 mins when charging finished.

Firmware is 3.3.1

Hi,

your screen shots are a bit confusing as you say your Firmware (wifi) is 3.3.1 but that is not indicated on the screenshot it shows 0.0.0 also the EVSE firmware shows as 0.0.0 this is what mine shows, it may be worth updating both to the latest versions.

John

@JJC Thx for yr response and screenshot – very welcome.

And sorry that my screenshots caused confusion – so to recap:

The unit is single phase and built from a kit a couple of years ago to which I recently added the latest WiFi card (v3.3.1). This configuration has run without problem for a few months. And the firmware has not been changed in this period of time.

This appears at the bottom of each openEVSE webpage:

Powered by openEVSE and OpenEnergyMonitor Version v X.X.X

When running normally it’s v 3.3.1 but when the Safety Warning is displayed, it’s v 0.0.0.

The following screenshot shows my Hardware Firmware when things are running OK:

My openEVSE firmware is 3.11.3 (kit version?) compared to your 7.0.2.EU.

However our openEVSE WiFi firmware is identical.

When the Safety Warning appears, my Hardware Firmware info disappears as per the following screenshot:

Thx

Hi,

mine is the same as yours built from the kit. However last year I updated the EVSE firmware following this thread Upgrading OpenEVSE / EmonEVSE Controller Firmware using ISP programmer - Integrations / OpenEVSE - OpenEnergyMonitor Community

Not sure it will fix your issue but there is quite a difference in versions.

John

I found that I was getting weird values / warnings etc. when the wi-fi connection between the unit and my house network was barely suitable.

My solution to that was to install a dedicated access point inside the house as near as possible to the unit outside and that solved the problem.

@greentangerine
Thx - a poor wireless connecton could explain the apparent randomness of the problem.

However when the Safety Warning is being displayed, I can still browse on the network to openEVSE.

Is there a separate wireless communication channel between the EV(Tesla) and openEVSE?

Yes, I could browse to it too.

One of the clinchers was that the MQTT feed from the unit would usually show as unconnected when this happened (and I wouldn’t be seeing the values on my local emonpi feeds).

I have since also updated the firmware but the problem had gone away before then.

@greentangerine
Thx for the further input - most helpful.

When the Safety Warning is displayed, I too lose the MQTT connection - must check next time what emon Feeds are affected.

Re wifi strength - openEVSE is installed on the outside wall of the ground floor office. Inside the office just 3 metres away is a quality router ‘broadcasting wireless’.

What exactly was yr solution?

I wonder if the wifi sensitivity of openEVSE can be improved?

Thx

PS: From yr experience- it doesn’t seem to be related to firmware version - and regardless, my wifi firmware is the latest ver 3.3.1

I put the OpenEVSE on its own AP using a devolo dLAN 500 i.e. a different SSID from the four TP-Link EAP245 units which provide a common SSID wi-fi to the house. The AP is inside and about 2m away.

I also use another dLAN 500 to route the two wireless relays I have in the garage to control the thermal store immersion heaters which are driven by an Eddi.

In my case, I think it was a combination of poor signal added to the wireless modules in such units not liking one SSID with multiple BSSIDs.

Anyway, with that sorted I don’t have any trouble now and it charges the Zoe and MG5 perfectly, usually on a timed charge during the Octopus Go cheap tariff period.

@greentangerine
Thx for the extra info.

Since my last post, I’ve had another episode of Security Warning which cleared itself after a period of time without action on my part.

From the screenshot it’s clear there’s a wireless problem as the SSID box is empty.

A subsequent forum search has revealed a lot suggesting that ESP wifi may be unreliable.

Yr AP is inside and 2m from the charger. In my case, it’s 3m from a quality router with 3 stubby antenna.

There’s a Raspberry Pi in an enclosure also mounted nearby on the outside wall. It’s on the same SSID as openEVSE. iwconfig indicates Signal Level=-53dBm and so my router inside is ‘pumping it out’.

I discovered there was a wireless firmware update to ver 3.3.2 in October but I haven’t yet managed to install it.

Thx

This sounds like a communication issue. If you open up the Developer Tools on you browser, and look at the network tab, you will probably see some failed fetches.