Community
OpenEnergyMonitor

Community

Olimex ethernet module flashing issues

Tags: #<Tag:0x00007fc9bbcf3460>

Hi,

I mistakenly flashed the firmware.bin instead of the esp32-gateway-e.bin (via web ui) on one of my EmonEVSE’s olimex ethernet modules. I now cannot seem to flash it back, web UI is not working.

I’ve tried using the to flashesp32-gateway-e.bin and bootloader.bin and partitions.bin using esptool.py with the board connected via USB, but it get:

esptool.py --baud 921600 --before default_reset --after hard_reset write_flash -z --flash_mode dio --flash_freq 40m --flash_size detect 0x1000 bootloader.bin 0x8000 partitions.bin 0x10000 esp32-gateway-e.bin
esptool.py v2.8
Found 1 serial ports
Serial port COM4
Connecting........_____....._____....._____....._____....._____....._____....._____
COM4 failed to connect: Failed to connect to Espressif device: Timed out waiting for packet header

A fatal error occurred: Could not connect to an Espressif device on any of the 1 available serial ports.

I’ve tried holding down one/both of the buttons during flashing but made no difference.

For anyone with similar issues, the fix was to use the driver from olimex’s site here:
https://www.olimex.com/Products/IoT/ESP32/ESP32-GATEWAY/open-source-hardware.
The one that had been installed via zadig seemed to be the issue for me.