Old EmonTx Fault

I have an old EmonTx V3 and it keeps stopping. Until a few days ago it had only done it a couple of times in the last year and powering down and back up fixed it, but now it either only stays on for an hour or 2 or doesn;t come back up at all.

Has anyone had a similar problem or any ideas to fix?


I’d suggest checking the power supply, then looking at all the standard things for a dry joint as the first moves. Which V3 is it, V3.2 with the RFµ module or the V3.4 with a RFM12B/RFM68CW directly on the p.c.b.

1 Like

Define ‘stopping’. Receiving data from it? Try connecting it to a PC via the UART and see what happens. If you continue to see data then the issue is probably the RF. You can easily convert to collect/post data with a Pi zero.

@Robert.Wall @borpin

Thanks both. I had tried a different power supply (it’s powered from the AC adapter) with no improvement. However, I tried a USB power supply on Sunday and it’s been working since. I am getting power readings with a bigger error though; I’ve tried it with and without the ac adapter plugged in; I have another voltage input from the emonpi and they are tracking each other to within about 0.3V, which doesn’t account for the difference in the power readings I’m now getting, so will have to do a bit more exploration.


Tell me which V3 it is.

Strictly, the 9V AC/AC is a sensor rather than a Power Supply. Generally better to use the 5V to power the unit. IIRC the older TX3 had a jumper to switch to manage this. The order of powering up is important - 9V first then 5V (IIRC). I generally then hit the reset button just to be sure the 9V sensor has been detected (it only does this at power up).

As Robert said, get the version number off the Board and there is probably a newer firmware build you can load.

The 9 V and the 5 V inputs use different regulators, and there are detail differences between the two versions, hence the question about which version, 3.2 or 3.4.

This suggests a problem with the MCP1754, or maybe more likely, the half-wave rectifier supplying it. Knowing the voltage on the 47 µF (V3.2) or 100 µF (V3.4) capacitor, which smooths that supply, would be useful.

The bigger error is probably because without the 9 V being detected, it guesses the mains voltage is a constant 230 V - which it won’t be, and the load power factor is 1.0, which it won’t be either.

Strictly, only when both are present. Without the 5 V, the a.c. adapter fulfils both roles at the same time, but this restricts the ancillary items that can draw from the 3.3 V rail.

1 Like

If you’ve changed the 5V power supply, did you use a decent quality replacement, random cheap USB power supplies found in a box of spares are rarely any good. There have been many discussions regarding this on these very forums, leading @TrystanLea (IIRC) to test a number of power supplies with an oscilloscope and find them remarkably rubbish!

You do remember correctly: Not all USB power supplies are created the same - Blog | OpenEnergyMonitor