Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Odd readings - Sampling spikes?

Hi I wonder if any one can sort out some sampling spikes I’m getting? I have just purchased a emonpi. I have one clamp around the incomming feed to the propery and another around the feed to a office. I’d like to log three values, incomming feed, house feed and office feed. I have set up the inputs as follows
image
In general it seems to work but when I turn off a heavy load in the office (instantanous water heater) I get negative spikes in the house values…
image

Welcome, Gary, to the OEM forum.

I think it’s a timing problem, and nothing to do with sensing the power as such. It’s for exactly this reason that “power1pluspower2” is made available.

But - I think you can use that to your advantage. If you reverse the c.t. on the office feed, it will measure a negative power. “power1pluspower2” then effectively becomes “power1minuspower2” and that’s your HousePower. All that’s left is to multiply the OfficePower by -1 to make it positive again before you do any more processing.

So you need three sets of processing:
Power1:
Log to feed → Total Power
Power to kWh → Total kWh

Power2:
× (-1)
Log to feed → OfficePower
Power to kWh → Office kWh

Power1plusPower2
Log to feed → HousePower
Power to kWh → House kWh

I think that should at least reduce, if not remove, the problem.

Hi Robert, thanks for the prompt and educated response. Did exactly that and the spike has gone.


As you say I think it was a timing problem where one sample came in before the other had updated.

Its nice to begin to understand what is happening with our energy consumption. In this case washing machine and tumble drier running in the house and then flip the hotwater tap in the office and watch the incomming supply voltage drop.

Want to add the water & gas meters next and both of those will need a reed switch (old style meters). Now have to investigate how and where to attach them and then how to get two pulsed inputs into the emonpi. I think I have seen a post somewhere about a direct feed into the pi’s GPIO.

1 Like

For the meters, sniff around the “fastest” wheel on the registers with an ordinary magnetic compass. If there’s a magnet in there, that should see it. If you have dials and pointers (still!), it’s a whole lot harder and probably not feasible to detect the pointers (though I did read a long time ago about using a computer mouse to detect the pointer going past - not here though). I rather doubt there’s a magnet in the electricity meter, you’re most likely going to need an optical sensor there to count disc revolutions.

The short answer to the Pi is you can’t by design because of the absence of connectors on the outside. (Or more precisely, there’s provision for only one on the RJ45 I/O connector.) If you’re willing and able to get wiring into the case, then try this Directly connecting to Optical Pulse Counter with RPi?

You can calculate the supply impedance (fault level) from that. :smile: In the 1980s, I worked on projects electrifying the winding engines at collieries. It was often said that in the village, they could count how many skips of coal came up on the night shift because all the light dipped each time the winder motor started. (In one case, the motor was 4000 H.P (~ 3 MW), d.c., pulling 8 kA during acceleration.)

Yes we are in a small lane in a village been fed by winie wires over poles. I’m wondering how much they willl start glowing once we all get electric cars.

I had seen that link, thanks. HW wise I’m reasonably capable but its the SW where I struggle. To that end a basic question? How do I set the Emoncms Log to DEBUG mode?

I want to post some values via the INPUT API. They work when posted by hand in a webrowser but the sending kit has limited TCP comms and I’d like to see what is missing from its posts to the PI

I’m not an emonCMS expert, so I could well give you the wrong information.

You set emonHub log level in emonhub.conf. It’s near the top of the file.
You set emonCMS log level in the settings.ini file. Edit it with Nano:

nano /var/www/emoncms/settings.ini

and set level = 1 – INFO (It’s right at the bottom of the file.)

Cheers. That worked but did not provide any more clues on why my device will not post. I’ll take a look again later.

Just installed a MID Modbus electric meter in the office DB so that will be another project