Octopus Agile emoncms app

It’s a standalone script at the moment to pull in the data, here’s the forum post that describes how to use it Python script to import Octopus Agile consumption data into emoncms

That sounds great, interesting approach!

Just to reiterate @borpin point about Proxmox.

Almost same here, at first just reused an old desktop (i3 / 8gb ram) for Proxmox, now using an old HP Microserver.

Has grafana, node-red, home assistant, influx, octolux etc etc all running as separate VMs, and/or as docker containers.
Gives you much finer grain control of the individual components if you wish to upgrade/shutdown etc/backup.

Well worth looking into.

1 Like

Ah, sorry, wires crossed I think, @TrystanLea. I have a feed (based on @borpin’s NodeRed solution) which has all my historic meter-reads under ‘consumption’ and timestamped according to the half-hour periods in question.

What I don’t have is the part in my version of your EmonCMS Octopus Agile App, which matches this:

I see no checkbox, ergo, I think I have an older version. It doesn’t appear to be part of the current EmonCMS core (i.e. that App never updated when I tried updating EmonCMS a couple of days ago), so I’m guessing it’s only available via your git page? If that’s the case, are there any special steps I need to perform in order to safely patch it in, without risking messing up future ‘normal’ EmonCMS updates? Or is it just a git-fetch and job done?


Also, @borpin and @Zarch - thanks for the idea of virtualisation and running HA on a bit of old (non-RPi) kit. I hadn’t thought of that. Virtualisation is still not in my ‘go-to’ mindset yet, but I’m slowly changing! LOL. I’ll give that a look… I have too much old kit laying about, that might lend itself to this…

I was using one of those until I put a power meter on it and discovered how much power it used compared to the laptop.

For me, most of my ‘parts’ are running in native PVE lxc containers built off the Ubuntu template rather than docker in a VM. AIUI, these are the equivalent of running docker on an OS.

The only VM is the HA OS one.

I had run VMs in the free version of ESXi for a number of years on the HP Microserver, but backup was a real pain. Proxmox is just so easy in comparison - well worth a dabble.

1 Like

It should just come in with an update. It’s in the stable branch. Perhaps try running update again and doing a full page refresh on the app page?

1 Like

From messing with various disk drives, if you have a SSD knocking about or indeed can stretch £25 for a low end 256GB, i’d highly recommend you install Proxmox (and VMs) on an SSD.

Takes away any nagging doubts from the outset when you get hung up on performance later. :grinning:


Ah. Thanks for the hint, @TrystanLea - as a result, I think I’ve sussed it:

Updating /var/www/emoncms/Modules/app module 
- git branch: stable 
- git tags: 2.1.1-42-ge5d51a4 
WARNING local changes in /var/www/emoncms/Modules/app - Module not updated 
- git status: 
On branch stable 
Your branch is up to date with 'origin/stable'. 
Changes not staged for commit: 
  (use "git add ..." to update what will be committed) 
  (use "git checkout -- ..." to discard changes in working directory) 
	modified:   apps/OpenEnergyMonitor/costcomparison/rates.js 
no changes added to commit (use "git add" and/or "git commit -a") 

Some time ago, I added data to the tariffs dropdown for the Cost Comparison App, so that I had the current regional version of the Octopus Fixed tariff that I was on at the time. I’m guessing this has marked my git as unstaged/uncommitted, and all bets are off. Derp. I can probably ditch those changes now anyway, because I’m on Agile.

It does highlight that the process of adding personalised tariffs to the Cost Comparison App might need simplification in the future, if that app is to become really useful to all, but I’m guessing you knew that already and development time-availability is the issue? :smiley:

Yes agree. As it stands I’m just using the original one in the laptop. I have a 256 SSD in my desktop, but I want to upgrade that so I’ll swap them around at some time. However, backups go to my NAS drive and a connected USB drive so restoring should be fairly painless.

Sorted. Now we’re cooking on gas. Or rather, we’re not. :grin:

Oh, and in case you (or anyone else) has any use for the following South Western area tariffs, @TrystanLea, I’ll leave them here for posterity. They were the changes to rates.js that was hanging up my auto-update.

label: "Octopus Go EV Tariff",
supplier: "Octopus Energy",
region: "SOUTHWEST",
updated_epoc: 1591996360,
// Rate 0 = peak 14.29 pence
// Rate 1 = off-peak 5.00 pence
rates: [{
    cost: 0.1429,
    colour: colour1
    cost: 0.05,
    colour: colour2
// Daily Standing Charge  = 25.00 pence
dailystandingcharge: 0.25,

identifier: "OCTOPUS12MFIXED2020",
label: "Octopus 12M Fixed 2020 Tariff",
supplier: "Octopus Energy",
region: "SOUTHWEST",
updated_epoc: 1591996360,
// Rate 0 = peak 15.29 pence
rates: [{
    cost: 0.1529,
    colour: colour1
// Daily Standing Charge  = 21.14 pence
dailystandingcharge: 0.2114,
rate_bucket: OCTOPUS12M_FIXED_2020

Thanks again for the help. Much appreciated.

1 Like

I’ve got Agile data importing as a feed, and can select it in the app for meter_kwh_hh. But I don’t see any sign that it’s working. No historic bars are dark blue, and there’s no calibration data in the console. I saw in another thread that smart meter readings won’t currently coexist with a solar PV feed. But I can’t get the app to ignore my solar feed! It defaults to auto, and even if I set the dropdown back to Select solar_kwh feed and hit OK, it just ignores it and uses it anyway. Any suggestions on how to persuade it to stop?

Have you also ticked the little checkbox below the graph on the Octopus Agile App page (not the settings, the display itself)?

Have you confirmed that you do actually have valid data for previous days, in your Agile data feed? i.e. if you go to the Graphs area, and select that Agile data (whatever you’ve called it), and use a data-interval of 1800 (half-hour), and a bar-chart style, do you see bars for each half-hour of the previous day(s)?

I’m not sure about the Solar PV issues myself (don’t have it, sorry)… but best to eliminate the obvious items first anyway, I think.

Yes to both. In the CSV view I see data points from July up until 00.30 today.

Creating a new copy of the app was how I got rid of the solar feed.

Hmm, I’ve tried that, but it auto-selects the solar feed on creating a fresh one, and I still can’t find a way to un-select it.

Just realised I don’t use standard feed names so auto does nothing. Other than changing feed names which is a bit drastic I think you may be stumped.

I just thought. Take a zero input that never changes. Create a feed and try selecting that feed as your solar input.

Nice idea, doesn’t seem to make any difference though.

What app version are you on? It should show up on the Setup>>Admin screen under EMONCMS Modules on the right.

App v2.1.8.

OK, same here. Latest version I believe. Will continue thinking! Ultimately this might be one for @TrystanLea to solve…

@nanoamp are you in a position to show us what you see on your screen?

For example, do you see a tick or a cross next to the solar_kwh settings option? Initially mine was blank (I have no solar), but I chose AUTO in order to compare notes, and it changed mine so that AUTO is now shown next to solar_kwh… however, it cannot find a legitimate solar feed, so it shows that X in a circle and displays nothing solar-related. I’m wondering if you can recreate the same effect by choosing a feed that is obviously nonsense, get the X to show, and you should be clear of it.

FWIW, I can no longer seem to remove the AUTO now either, but it’s not doing any apparent harm on my display… as far as I can tell!

This is what I see: