No inputs on emonBase using three phase emonTX

Hello,

I’ve written the 3phase firmware to my new emonTX but I don’t see it as an input on the emonBase (unfortunately I never tried with the stock firmware). My only available inputs are emonpi, emonth5 and emontx3cm15 – they all say n/a NULL but I’m not sure that’s related.

As per the docs I have checked the log file on the emonBase and do NOT see any DEBUG RFM2Pi 8 NEW FRAME : OK lines so I assume that the emonBase is not seeing anything from the TX.

The serial output on the TX is as follows (the CTs are not connected):

OpenEnergyMonitor.org
emonTx V3.4 CT1234 Voltage 3 Phase PLL example - Firmware version 1.40
Using RFM69CW Radio
No EEPROM config
Calibration:
vCal = 268.97
i1Cal = 90.91
i1Lead = 2.00
i2Cal = 90.91
i2Lead = 2.00
i3Cal = 90.91
i3Lead = 2.00
i4Cal = 16.67
i4Lead = 0.20
Network: 210
Node: 11 Freq: 433MHz
POST…wait 10s
‘+++’ then [Enter] for config mode
0.00 0.000 0.000 0.000 0.000 0.00 0.00 0.00 0.00 0.000 0.0000 0.0000 0.0000 0.0000 300.00 Pulses=1 PLL is unlocked
247.29 0.000 0.000 0.000 0.000 0.00 -48.63 -53.46 0.00 49.948 0.0000 0.0000 0.0000 0.0000 300.00 Pulses=1 PLL is locked
247.35 0.000 0.000 0.000 0.000 0.00 0.00 -0.10 0.00 49.986 0.0000 0.0000 0.0000 0.0000 300.00 Pulses=1 PLL is locked
246.64 0.000 0.000 0.000 0.000 0.00 0.19 0.46 0.00 49.979 0.0000 0.0000 0.0000 0.0000 300.00 Pulses=1 PLL is locked
246.31 0.000 0.000 0.000 0.000 0.00 0.01 -0.30 0.00 49.977 0.0000 0.0000 0.0000 0.0000 300.00 Pulses=1 PLL is locked

Does anyone have any ideas? I’ll be the first to admit that I’m a bit out of my depth (!!) but this is my first foray into Arduino/emon stuff and I’ve managed to get this far so I’m hoping it’s something really obvious!

Cheers,
Ben

What did you see? Was this the emonhub log?

The serial output suggests this is on Node 11, so there needs to be a decoder on emonhub to handle it.

You would hope to see something this in the emonhub log

RFM2Pi     xxxxx NEW FRAME : OK 11

where 11 is the node ID of the TX.

Hi Brian,

Within the log file of the emonhub i see:

2020-08-05 19:20:14,223 INFO     MainThread EmonHub emonHub (emon-pi variant) v2.1.5
2020-08-05 19:20:14,223 INFO     MainThread Opening hub...
2020-08-05 19:20:14,224 INFO     MainThread Logging level set to DEBUG
2020-08-05 19:20:14,224 INFO     MainThread Creating EmonHubJeeInterfacer 'RFM2Pi' 
2020-08-05 19:20:14,226 DEBUG    MainThread Opening serial port: /dev/ttyAMA0 @ 38400 bits/s
2020-08-05 19:20:16,229 WARNING  MainThread Device communication error - check settings
2020-08-05 19:20:16,231 INFO     MainThread Setting RFM2Pi baseid: 5 (5i)
2020-08-05 19:20:17,233 INFO     MainThread Setting RFM2Pi frequency: 433 (4b)
2020-08-05 19:20:18,235 INFO     MainThread Setting RFM2Pi group: 210 (210g)
2020-08-05 19:20:19,237 INFO     MainThread Setting RFM2Pi quiet: 0 (0q)
2020-08-05 19:20:20,240 INFO     MainThread Setting RFM2Pi calibration: 230V (1p)
2020-08-05 19:20:21,242 DEBUG    MainThread Setting RFM2Pi pubchannels: ['ToEmonCMS']
2020-08-05 19:20:21,243 DEBUG    MainThread Setting RFM2Pi subchannels: ['ToRFM12']
2020-08-05 19:20:21,245 INFO     MainThread Creating EmonHubMqttInterfacer 'MQTT' 
2020-08-05 19:20:21,249 DEBUG    MainThread Setting MQTT pubchannels: ['ToRFM12']
2020-08-05 19:20:21,250 DEBUG    MainThread Setting MQTT subchannels: ['ToEmonCMS']
2020-08-05 19:20:21,251 INFO     MainThread Setting MQTT node_format_enable: 1
2020-08-05 19:20:21,251 INFO     MainThread Setting MQTT nodevar_format_enable: 1
2020-08-05 19:20:21,252 INFO     MainThread Setting MQTT nodevar_format_basetopic: emon/
2020-08-05 19:20:21,253 INFO     MainThread Creating EmonHubEmoncmsHTTPInterfacer 'emoncmsorg' 
2020-08-05 19:20:21,255 DEBUG    MainThread Setting emoncmsorg pubchannels: ['ToRFM12']
2020-08-05 19:20:21,255 DEBUG    MainThread Setting emoncmsorg subchannels: ['ToEmonCMS']
2020-08-05 19:20:21,256 WARNING  MainThread Setting emoncmsorg apikey: obscured
2020-08-05 19:20:21,256 INFO     MainThread Setting emoncmsorg url: https://emoncms.org
2020-08-05 19:20:21,257 INFO     MainThread Setting emoncmsorg senddata: 1
2020-08-05 19:20:21,257 INFO     MainThread Setting emoncmsorg sendstatus: 1

and within the conf file I have:

[[RFM2Pi]]
    Type = EmonHubJeeInterfacer
    [[[init_settings]]]
        com_port = /dev/ttyAMA0
        com_baud = 38400                        # 9600 for old RFM12Pi (was set to 38400)
    [[[runtimesettings]]]
        pubchannels = ToEmonCMS,
        subchannels = ToRFM12,

        group = 210
        frequency = 433
        baseid = 5                              # emonPi / emonBase nodeID
        calibration = 230V                      # (UK/EU: 230V, US: 110V)
        quiet = false                            # Disable quite mode (default enabled) to enable RF packet debugging, show packets which fail crc
        # interval =  300                         # Interval to transmit time to emonGLCD (seconds)

and

[[11]]
    nodename = 3phase
    [[[rx]]]
       names = powerL1, powerL2, powerL3, power4, Vrms, temp1, temp2, temp3, temp4, temp5, temp6, pulse
       datacodes = h,h,h,h,h,h,h,h,h,h,h,L
       scales = 1,1,1,1,0.01,0.01,0.01,0.01,0.01,0.01,0.01,1
       units = W,W,W,W,V,C,C,C,C,C,C,p

Cheers,
Ben

What’s the physical distance between the emonTx and the emonBase?
What obstacles are there in the direct line between them?
Are the emonTx and emonBase recent purchases from the OEM shop? (The real question is, are they both using 433 MHz radio modules and working on 433 MHz?)

Hi Robert,

Same room – 5m max

Yes, the emonBase and the emonTX were both purchased a couple of weeks ago from the shop!

Cheers

In that case, I can’t see a good reason for the setup not working either. Everything looks OK to me. It should work:
The emonTx has successfully set itself up and is measuring and reporting, it says it’s using the correct NodeID, Group and frequency.
The emonBase is using the correct config. data, group and frequency.
At 5 m, it probably wouldn’t have worked if one or both of the radio modules was a 868 MHz one, but from the shop, both should be 433 MHz. And if those are correct, it should work through a couple of brick walls. (There are pictures in ‘Learn’ showing the differences.)

I presume you don’t have anything else working in the 433 MHz radio band (weather station, burglar alarm?) that could be interfering - though I’d have expected evidence in the emonhub log.

And I presume you don’t have anything else from OEM that could be used as an independent check?

My only theory at this point is one of the radios has failed - but in an unusual way. Usually they don’t respond at all, so if it was the emonTx, you’d never get as far as seeing the output you do see, and the emonBase would report it not talking.

If nobody else comes up with a good reason, I suggest you email the shop [email protected] and mention this thread.

Hi Robert,

Is there anything in any of the conf files which is commented out as default, that I could have missed? I’ve put a totally clean 3phase sketch on the Tx and the Base is running ‘out of the box’ but still can’t see any communication.

I’ve moved all the hardware to a different room (so it was closer to me) and that hasn’t made any difference. I’ve got a gate opener which is on 433MHz and an old Efergy pulse monitor but they’re both turned off and when turning them on, I don’t see anything in the emonhub log – would I expect to see anything? Is there any way I can get a running view of what the radio module can see?

Cheers,
Ben

You have often used the term “emonBase” but you also stated

Which specifically suggests an emonPi rather than a Pi with an attached RFM2Pi board, the latter being the common understanding of an emonBase (although technically they are both emonBases). Could you please confirm your hardware, type and age, and also which emonSD image are you running (or alternative).

If not an emonPi. Are there any signs of life at the RFM2Pi board? Does the LED illuminate at power up and/or occasionally when a packet is received? You’ll need to look close as it’s very small and easily missed in bright ambient light. Check the board is seated correctly on the first 10 (2x5) gpio pins and not touching/shorting on the unused gpio pins under it. Depending on age it may use a different baud (com_baud in emonhub.conf) try 9600 and 57600. If it is an older model and you have updated recently it may have installed the wrong firmware (rfm69cw rather than rfm12b).

If it is an emonPi, oh dear! None of the above is likely to apply and other debugging may be needed.

In either case, stopping the emonhub service and trying to access the serial port directly with miniterm might be useful.

I assume you do not have anything else trying to use the gpio serial port? Or that you have changes any of the serial port mappings in the config.txt etc.

your emonhub is configured to show all rf packets, good and bad.

You can see it tries to set the RFM2Pi/emonPi board with this command

But there is no confirmation as the serial connection has already failed at this point.

If you use Miniterm (or other serial terminal) and send 0q you should then see all traffic.

EDIT

Just re-read and saw

Which does answer much of the above, but not why you see an emonpi node, so if you could just clarify (again?) that would be great.

Hi Paul,

Thanks for your assistance :slight_smile: I’ve responded in-line below:

It’s an emonBase - web-connected base-station - which according to the shop is a Raspberry Pi + RFM69Pi add-on board. I purchased it all fully assembled last month and I also got a pre-loaded SD card. It’s a Raspberry Pi 3 Model B Rev 1.2 - 1GB (Embest), currently running emonSD-17Oct19.

It’s not an emonPi, it’s definitely a Base. There is no LED on the RFM69Pi board – I can’t actually see where the LED would be but in darkness there is no light being emitted from anywhere. It’s using pins 3-12 i.e. one pair in from the edge. I haven’t upgraded/changed anything.

I guess we’re currently at:

emonPi/emonBase – do these require different images? I note that you are surprised at my available (n/a NULL) inputs?

GIPO pins – I didn’t install this but the pins are not 1-10 as you note, however the board is a RFM69Pi and not a RFM2Pi so I haven’t moved it along one for fear of damaging it but of course will do if this is likely the problem!

Thank you for your help.

Cheers,
Ben

That’s the problem. The two connectors should line up on the end at the very corner of the p.c.b.

(I’ve PM’d Gwil.)

Hallelujah!!

Thank you all. I’ve never been so happy to see this screen!