No graphs in dashboard following update

I’ve done a git pull after several months of excellent emoncms use on debian wheezy, and all went well except graphs no longer appear in my dashboards. Everything else seems to work, and graphs are fine on their own (in the data viewer). I can select them in the dashboard menu but I only see the top control bar when they are placed on the dashboard. I’ve done a database update and pulled everything I can see! Admin says:

|Emoncms|Version|9.8.27 | 2017.12.21|
||Modules|Administration | App v1.0.0 | Backup v1.1.1 | Dashboard v1.1.1 | EventProcesses | Feed | Graph v1.1.0 | Input | CoreProcess | Schedule | Time | User | Visualisation|

A possible clue is that there is an extra double-headed arrow in the control bar of the graph (not) displayed on the dashboard, but it’s not there in the data viewer version, so maybe they are using different code.

I’m a bit stumped. Any ideas what to do next?

Did you update the databases from the admin screen?

Dashboard is a 1.1.2 and is a separate repo Releases · emoncms/dashboard · GitHub

Hi Brian – yes.

Update: I just tried if from my phone and everything worked fine, so I went back to my laptop and cleared the browser cache – all is well again! How silly of me. Anyway that’s a hour of messing about that maybe someone else won’t have to go through!

Thanks for your help. I’ll try the newer dashboard too.

1 Like