Nibe SMO USB faulty?

Hi everyone,

I am facing an issue when trying to update the software in my Nibe SMO 20. The device is running is: 9542R2.

When I connect the USB to the front of the Nibe, nothing happens. No USB menu shows up, but the light of the USB stick does go on.

Things I tried:

  • 6 different USB sticks, all formatted with FAT32.
  • different software versions (SMO_20_v9696R2.nibe recommended by the Nibe Uplink), but also: UPGRADE_v3000R3.nibe, and nibe-n-3_0_10.swu). If I put any of these in the USB stick it makes no difference, no extra menu item shows up.
  • disconnecting the UTP cable (just in case)
  • restarting the device (by switching to standby and then back to on)
  • unplugging and plugging back it the Nibe

I am a bit out of ideas. Could you guys please help me to figure this out?

Hi Roger. Welcome to the forums. It’s good to see another NIBE owner on here.

I have an F1145 (Ground Source) and the embedded controller in that uses the same hardware as the SMO 20.

My own experience is that the USB interface is very sensitive to the USB drive and how that is formatted. In particular, I’ve had problems with software files saved onto partially-filled USB drives not being seen by the NIBE controller; it only seems to find them if the software is ‘near the start’ of the drive’s File Allocation Table.

My recommendations would be:

  • Bear in mind the hardware design of the SMO 20 is over 10 years old so it ‘expects’ to see a type of USB drive that would have been available at that time
    • Something of the order of 1 Gigabyte in size and using the USB interface standards typical of that time - e.g. not USB 3.0
    • Try using the oldest / smallest USB drive you have to hand
  • Re-format the USB drive and write the NIBE files as the only files on the drive
    • It’s important to re-format the drive - I wasted a lot of time trying to get it to work by deleting other files so the NIBE software files were the only ones left, but that didn’t help - they need to be pretty much the first files ever written to a newly-formatted USB drive

My hunch is there are some bugs in the File Allocation Table processing in the NIBE controller firmware which means it’s not fully implementing the FAT32 specification.

David

1 Like

Well, this was spot on, thanks a lot davidMbrooke! I tried with a pretty old USB (8 Gb) and just did the trick! :smiley:

Yay! Pleased to hear you’ve got it working.

This sort of issue is likely to become increasingly common for ‘embedded’ systems like this which are part of (hopefully) long-lived appliances - while the rest of the IT world evolves rapidly, tending to leave them behind.

It’s probably a good idea to reserve an old / small USB drive just for this purpose - although the new myUplink does over-the-wire updates so there should be less need for messing with USB drives moving forwards. (I’m still waiting for myUplink to become available for my F1145, so I’m on the old NIBE Uplink for now.)

Indeed I am glad that I had that old USB around. I recently bought a house that came with that Nibe and is connected with Watts RF thermostats using Watts RF 868MHz for the floor heating, but I am still trying to figure out how it all works.

Interesting. It’s absolutely A Good Thing that heat pumps are becoming common enough that quite a few people are ‘inheriting’ them when purchasing a property - but that’s a very different experience from being the person who makes the decision to have one installed in the first place.

We’re here to help when you have further questions. For example, @etchelsa has been on a similar journey to you, having inherited a NIBE system when buying a house.