New First User Creation Error


I create My 1st user creation i got error “[object Object]”,

How to solve this error,

Please help to solve this error,

I am now using Shared Host

Hello @kumarmohan7, could you check your apache2 logs? do you see any errors there?

Hijacking this. Seeing this error too. I am using NGINX with https letsencrypt certs. It complains about mixed content not being loaded for security. When I disable security for my site and allow it to load the JS scripts, creating the first user also gives me that Object Object error.

No logs in emoncms.log or NGINX but the web console is screaming. Sorry for the messages in French, this is where i currently am. Though error messages should be straight forward. This is on Firefox.

L’utilisation d’XMLHttpRequest de façon synchrone sur le fil d’exécution principal est obsolète à cause de     son impact négatif sur la navigation de l’utilisateur final. Consulter pour plus d’informations.
Chargement du contenu mixte actif « http://xxx/user/register.json » (non sécurisé) sur une page sécurisée[En savoir plus]
Blocage d’une requête multiorigines (Cross-Origin Request) : la politique « Same Origin » ne permet pas de consulter la ressource distante située sur http://xxxx/user/register.json. Raison : l’en-tête CORS « Access-  Control-Allow-Origin » est manquant.

Got curious, tried with Chrome and also got Object Object with the following message in the web console:

jquery-1.11.3.min.js:5 Mixed Content: The page at 'https://xxxx/user/login#' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://xxxx/user/register.json'. This content should also be served over HTTPS.

Disabling https still has problems, when trying to create the new user, I get:

[Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check
send @ jquery-1.11.3.min.js:5
ajax @ jquery-1.11.3.min.js:5
register @ user.js?v=1:29
register @ login:259
(anonymous) @ login:214
dispatch @ jquery-1.11.3.min.js:4
r.handle @ jquery-1.11.3.min.js:4

My git clone is from today: | 9.8.31 | 2018.06.21

Which branch (not that I can help but others will need to know :smile: )?

Whichever was selected when I copied the link from the main page, guessing master?

git -C /var/www/emoncms/ status (with the right path) will confirm the branch.


$ git -C . status
On branch master
Your branch is up-to-date with 'origin/master'.
nothing to commit, working tree clean

Tried stable too, same error.


I am unable to login to any user, old or new. This happened during one of the last updates!
I am now on 9.8.31, no errors are seen in any of the logs…

Try a database update using the script.

I tried that script, i got an output of a change it made to the database, when I run it again nothing happens so I guess it worked.
It does however not solve my problems.
When I try to log in, it loads to the login prompt again, no errors anywhere.

I am also getting this error with a blank EmonCMS setup - can’t log in at all (after registering an initial user).

EDIT: Issue fixed. I submitted pull request 931 and it has now been accepted.

1 Like

@anna_carboncoop Thanks a LOT! This change fixed my login issues!!

1 Like

I was unable to implement this fix, but I still have the same problem with the first access to emoncms.

Can anyone help?

Which fix?

What exactly are the symptoms and what have you tried? What system are you on?


I’ve used the git installation guide:

My environment is an Amazon EC2 Debian Linux.

On the first access, the error message “[object Object]”

So much to create a create a user or login.

Could you try updating emoncms again (master branch) and retry? There has been some new code merged today that might fix this, you may need to clear the browser cache too.

(Ref fix for #791 & refactor and fix bugs in dbschemasetup by takkaria · Pull Request #930 · emoncms/emoncms · GitHub and Remove null=true from database schema, fixing #1016 by takkaria · Pull Request #1018 · emoncms/emoncms · GitHub)

1 Like

I tried the upgrade procedure. But it did not work.

I deleted all previous installation, and installed again, but still presenting the error in the login:

[object Object]

I also performed the procedure:

5.1) If you can not login
If you can not login, use the authentication bypass to run the updater.

Add the following line to the bottom of settings.php to enable special database update only, be sure to remove this line from settings.php once complete:

$ updatelogin = true;
In your internet browser open the admin / db page to launch the database update script.

http: // localhost / emoncms / admin / db

I did not succeed! :cry:

I’ll be grateful if anyone can help.