Community
OpenEnergyMonitor

Community

New EmonTH v2.0.2 + does not work on 868Mhz but 433 Mhz

Tags: #<Tag:0x00007fc923cea5b0>

Dear All,

I have an EmonBase (on raspberry 1 (one of the first ones) + 11 modules (THs and TXs) running 5+ years now. Unfortunatley one of the EmonTH modules (that was setup outside) got broken, hence i ordered a new one. My fault, but I did not follow the forum at openenergymonitor closely in the past years, so I missed the info, that modules with 868 Mhz are cannot be purchased anymore, but only with 433 Mhz.
As all my existing infra is on 868Mhz i am looking for a solution (if any) to be able to make this recently purchased EmonTH to work on 868 Mhz.
What I tried was to change the RF configuration -using serial monitor- to 868 Mhz, i also was able to change the node and the group, but even after saving the new settings to the Eprom, this new module is still not able to commmunicate with the Emonbase. I have also replaced the Antenna from the old, 868 Mhz module to the new 433 module, but no luck.

When I changed the frequency in the emonhub.conf file on the emonbase to 433 from 868, the new module started to work/communicate with the base station (so the HW is OK), but of course, none of the other modules were working. Changing back to 868, all existing modules were working except the new one.

I would like to know if there is a way to configure this new EmonTX module (v2.0.2) to work on 868Mhz.
I did not change the firmware on the TH, I am using the one which this was shipped with.

I do not know, if the older (5+years) TH and TX modules could be re-configured to 433 Mhz, + that would be a lot if work (which is fine if that is the only available option for me now.)

Many thanks for any hints.
Best Regards,
Attila

The 433 Mhz module can be made to work at 868 Mhz, BUT, the range is severely limited.
(not more than a meter or two, at best) Unfortunately, that makes what you want to do not feasible.

Hi Bill,

Thanks for the prompt response. This is a quite bad news :frowning:

Do you happen to know the answer what happens to the older modules, that are on 868Mhz… is it possible to change them to 433? Any downside -if possible at all- of that change?

Thank you
Attila

Unfortunately, the modules are - for lack of a better term - hardwired, to operate on their
assigned frequencies. As I mentioned, they can be forced to work at one of the other frequencies, but because of the internal construction of the module, output power is greatly reduced, hence the significant loss of range.

Operating one on a frequency different than it was designed / manufactured to operate on, is usually done only as a test. e.g. to do troubleshooting, or a hardware check.

I think your best solution will be an EmonBase 433 module on a PiZeroW with just the emonhub software installed forwarding the data from the 433 EmonTH to the existing EmonCMS setup.

This then also future proofs you if any further 868 modules stop working.

1 Like

If you have the right skills and tools, you could unsolder the 433 MHz module and substitute an 868 MHz one. The danger is, without experience of working on small circuit boards like the emonTH, you risk catastrophic damage to the main circuit board.

Hi Borpin,

Thank you for the advice, I think this is the less painful option in this case.

Attila

Hi Robert,

Nope, unfortunately neither proper tools, nor the skillset is available for the module replacement and i dont want to damage the TH, as it is working.

Thanks
Attila

No bother. If you need any help setting it up feel free to ask. Key thing is just install emonhub not the full Emoncms.

Ack, thx :slight_smile:

An even easier option is adding a jeelink to your existing pi.

Essentially it’s a rfm2pi in the form of a usb dongle, emonhub can run several rfm networks, you just configure a second “rfm2pi” interfacer in emonhub.conf and that’s it.

2 Likes

Thanks @pb66 for the link.
If i get it correctly then using this usb stick i can make the existing emonhub “hybrid” in a sense, that it will be able to handle both frequency ranges. i just need to use the required version of RF attached to the stick.

1 Like

Correct, just buy a 433 jeelink and you’ll have both frequencies covered.

Although you need to weigh up the pro’s and con’s as to whether this works for you, if you are not likely to expand your system (or break any more :smile:) then it might be worth asking the OEM shop if they can supply a 868MHz emonTH for you. They are no longer stocked, but they can apparently do them to special order (or at least they used to). This would “keep things tidy” but you are perhaps just “kicking the can down the road” if you do eventually want to expand or if more fail, in which case you might well be better off adding a 433MHz transceiver.

You might be able to flog (or return?) your 433 emonTH if the shop can do you a 868 version.

1 Like

Hi All,

So just to close out this thread, -maybe it will be useful for others as well- I wanted to share what path I chose to address my original problem and so be able to use both legacy 868 and new 433 Mhz modules in my home environment without setting up a second(ary) Rpi. (There were other suggestions also that would have worked, but I chose Paul’s idea finally, because I did not want to duplicate the number of gadgets at home if it is not neccessary.

Unfortunately the “re-org work” did not go smoothly there were couple of issues as well during the change/work, but finally I was able to set it up, so I thought I share those steps I went through. I have to mention that I dont use and know linux at all, so possibly my lack of knowledge in this area was the reason of these failures :slight_smile:

So, given in EU 433Mhz is the approved freq, I bought another RFM69Pi module which is running at 433 Mhz and also bought an 866 MHz JeeLink USB stick. So the JeeLink will serve the legacy/old devices and the RFM69PI will be for future ones.

Downloaded and Installed the EmonCMS (October 2018 version) to the Raspberry and upgraded both the JeeLink and the RFM69Pi firmware with RF12demo.14. (JeeLink did not seem to be work with previous version of firmware, but once .14 is installed, the power light turned blue, and finally I could see the RX red lights flashing as data came in). I have also edited the emonhub.conf file, by adding the JeeLink reference to the [interfacers] section:

 [[JeeLink]]
        Type = EmonHubJeeInterfacer
        [[[init_settings]]]
            com_port = /dev/ttyUSB0
            com_baud= 38400
        [[[runtimesettings]]]
            frequency = 868
            group = 210
            baseid = 5
            quiet = false

           pubchannels = ToEmonCMS,
           subchannels = ToRFM12, 

After all these steps were made (+service reset + restars) I did not see that my data/dashboards are refreshing at EmonCMS.org and I was also missing the JeeLink entries from the Emonhub logs (Apart from the ones, that were about the JeeLink setup to use the defined Node ID, GroupID and Freq…etc). And also there were lots of errors like this one below:
"Discarding RX frame 'unreliable content'? 26 121 96 94 157 25 180 235 51 216 47 38 85 231 115 155 7 203 223 69 245 (-84)"

Which might be OK, as all (except 1) modules are on 868Mhz and the RFM69Pi is at 433Mhz. (The brand new EmonTX at 433 Mhz was working, but none of the others at 868Mhz that were supposed to use the JeeLink)

So to check if JeeLink is accessible on the /dev/ttyUSB0, I ran the dmesg command on the PI.

 $ dmesg | grep ttyUSB
[    4.558137] usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB0

Looks good, as the Device is definitely there.

Side note: When I upgraded the firmware of the JeeLink in Arduino, after testing the results, by using the serial monitor, I was able to see that the Jeelink was getting data, i could see all my 868Mhz nodes were sending reports and Jeelink was able to catch them.

So I searched for a simple script I could run in the rasberry, to check if Jeelink is still working and is able to grab the data coming from the nodes. I found the below python script on this site

import serial, sys
ser = serial.Serial('/dev/ttyUSB0', 38400)
while 1 :
sys.stdout.write(ser.readline())

Looks like the Jeelink is working as grabs the data from the nodes…

[email protected]:/tmp $ sudo python test2.py
OK 17 23 0 0 0 0 0 216 0 211 0 211 0 (-51)
OK 10 37 2 0 0 250 255 37 0 173 99 202 0 (-56)
OK 20 193 0 0 0 0 0 22 0 (-66)

But for reason or another I still did not see any Jeelink entries in my Emonhub.logs. I did several service restarts and reboots, but that did not help.
Unfortunately i am not a linux expert (quite far from that) so as a final try (before reaching out to this audience for help) was to try to do an EmonCMS upgrade using the Admin page through the UI. And voila. After the upgrade and some restart afterwards it started to work.

2019-11-16 16:17:56,321 DEBUG    RFM2Pi     Discarding RX frame 'unreliable content'? 23 130 93 255 177 44 63 97 158 74 179 21 139 95 185 189 131 61 231 121 160 (-80)
2019-11-16 16:17:58,645 DEBUG    RFM2Pi     Discarding RX frame 'unreliable content'? 20 36 32 53 228 213 246 164 155 231 0 219 102 221 233 47 29 119 35 71 26 (-83)
2019-11-16 16:17:54,068 DEBUG    JeeLink    8324 NEW FRAME : OK 20 195 0 0 0 0 0 22 0 (-70)
2019-11-16 16:17:54,071 DEBUG    JeeLink    8324 Timestamp : 1573921074.07
2019-11-16 16:17:54,072 DEBUG    JeeLink    8324 From Node : 20
2019-11-16 16:17:54,072 DEBUG    JeeLink    8324    Values : [19.5, 0, 0, 2.2] 

Maybe the upgrade was completely unrelated in the resolution, but anyhow, in the end it did the magic and the JeeLink together with the RFM69Pi works just fine, and all my graphs and dashboard are getting updated again as expected.

Regards,
Attila

3 Likes