New EmonTH not working - no transmissions

Hi all, I have just got some brand new EmonTHs after the long gap when they weren’t available.

I have just tried setting a new one up for node id 26 (both dip switches on) but I am not receiving anything from it. I have looked in the Emon Hub log and I get no frame messages from id=26. I am getting frames from my 3 old EmonTH modules at ids 23, 24 and 25 so my original system is working fine.

I have tried another new EmonTH which is the same, no transmission. Batteries are good and there is 3.3V on the pcb. Little green led comes on when batteries are inserted and goes off after a few seconds as expected.

Any ideas?

Ah - is this the new encrypted radio format? How to turn it off or selectively enable per EmonTH in EmonPI?

Welcome, Neil, to the OEM forum.

I don’t know whether the emonTH is now shipping with the LPL library - this is a question for @Gwil - but this page Firmware — OpenEnergyMonitor 0.0.1 documentation suggests it is and if it is, you’re right as it’s the most likely explanation. Unfortunately, it means reloading either ‘old’ sketch or recompiling and reloading the new one to get it to work with your emonPi.

I’m afraid

could never work, because all the decoding of the ‘new’ format message is done inside the radio module and it must be set up beforehand to decode and decrypt the message, whereas the ‘old’ format message is handled in the ATMega 328P - and of course it’s impossible to know whether an ‘old’ or a ‘new’ format message will arrive next in order to switch the receiver around ready to receive it.

If you have a programmer, the page I linked above tells you how to use your emonPi to upload the sketch, which probably means your emonPi needs the latest emonCMS first :worried:

There is an option on the product page, the default is LPL

@NeilMc to fix this you either need to update the new emonTHs to run JeeLib ‘compatability’ FW, or update your receiver existing (emonBaser or emoPi) to be able to receive data on the Low Power Labs (LPL) encrypted FW that’s now the new standard, you would also need to update any other nodes. See here for an overview of RF formats: 433MHz Radio Format vs Device — OpenEnergyMonitor 0.0.1 documentation

The easiest thing to do is probably to change the FW on the emonTHs. To do this you’ll need to:

  • Update your emonBase or emonPi to latest software by running Admin > Update> Full Update in local Emoncms
  • Using a USB to UART programmer cable plug the emonTH into your emonBase or emonPi
  • Select Admin > Update then under the FW update section select the /dev/ttyUSB0 serial port, emonTH2 hardware and JeeLib Classic FW as shown below
  • Click update

Thanks Glyn, that looks like the way ahead. I have the usb programmer as I was intending to tinker with the EmonTH configuration (although I haven’t used it yet).