My latest emonpi device not show wlan0 interface what is happening?

i have buyed an latest emonpi device but on lcd display it says wifi not connected.
On cms interface wifi not detect any…
on ssh interface i no see wlan0 interface.
what i have to do?

Hi, sorry to hear your having trouble.

When did you order from us? Do you know your order numbre? Do you know if you have the latest RaspberryPi3 with on-board Wifi? If you do one side-plate on the emonPi enclosure will be black acrylic plastic.

If you ordered some time ago and have an older RaspberryPi 2 you will need an external Wifi USB adapter.

If you have SSH access you can find out what RasPi you have by running:

$ grep 'Revision' /proc/cpuinfo | sed 's/.*: //'

If this returns a02082 then you have the latest RasPi3 with on board wifi. If it returns a01041 then you the older RaPi2 without on-board wifi. See here for more info on hardware identification:

Hi all

I’m having massively problems with the WiFi interface as well. I’m running the Rasperry V3 (I’m running 4 pcs at the moment) and all of them don’t show a wlan interface.

The strange thing is that a couple of weeks ago I could connect via wifi - the menue with different wifi networks shown up, but I don’t know why and what caused loosing the interface. I checked the RFP HW and they are all “a02082”.

The emonpi image is this version “low-write 9.7.8 | 2016.11.10”.

Even pressing all the buttons on the wifi page does not help.

Any help?

Oh dear, sorry to hear you are having trouble.

Can you connect via SSH then post the output of:

$ cat ~/data/wpa_supplicant.conf

Hy Glyn

this is the output

[email protected](ro):~$ cat ~/data/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev 
update_config=1

Ok, thanks. So that means no WiFi config has been saved.

We can check if the Wifi is working by running a manual Wifi scan. Connect via ssh then run:

$ sudo iwlist wlan0 scan

You should see a list of available networks.

If the manual network scan works ok, the issue must be with Emoncms Wifi module. To help debug could you try and open the Emoncms wifi config page with developer console mode open in your web browser (CTRL + SHIFT + J) on Chrome Browser. Can you see any errors on the page?

I am unable to reproduce the issue myself. Do any of your Wifi networks in the vicinity have any special characters or spaces?

this is the Output of

$ sudo iwlist wlan0 scan
wlan0     Interface doesn't support scanning.

The strange thing is that in the browser (either Crome, Firefox, or iE) there is nothing shown up from the wifi scan arey (the green area).

Would you like to login by your selfes ? I can open a port for you… (would need your email)

I get this same message when the Edimax WiFi USB Adapter is unplugged (I have an emonPi on the RaspPi 2B). Assuming a RaspPi 3B, maybe the wifi interface is turned off.

I am curious… If you SSH into the emonPi and type in:

sudo ifconfig

You should see three interfaces: eth0, lo and wlan0. It should look something like this:

[email protected]:~ $ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet6 addr: 0000::0000:0000:000:0000/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:258 errors:0 dropped:0 overruns:0 frame:0
          TX packets:258 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:25463 (24.8 KiB)  TX bytes:25463 (24.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.00.232  Bcast:192.168.00.255  Mask:255.255.255.0
          inet6 addr: 0000::0000:0000:0000:0000/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2803211 errors:0 dropped:575077 overruns:0 frame:0
          TX packets:1520380 errors:0 dropped:2 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:52740643 (50.2 MiB)  TX bytes:2588215591 (2.4 GiB)

[email protected]:~ $ 

Oh dear, this is very strange. If your running a RasPi3 as sold via the shop with the pre-build SD card the Wifi should be enabled. Yes please send me a private message via the forum with the address for you emonPi, I’ll take a look.

It looks like you have a faulty Raspberry Pi ,the Wifi hardware does not seem to be working. We will send you a replacement. Please let us know if this works for you.

Hi Glyn

thanks for your help. But I both 15pcs RPI’s V3 from Farnell.

So doubt that there is a HW failure because it can’t be that all 4 HW
are defect…

Regards

Juergen

Glyn, may I ask you a question over this way? It’s about the
communication between emonpi rasperrypi and the rest of the sensor HW.
The communication is done over serial. And is there a way for a
bidirectional protocoll? So what I mean is, is there any implementation
where the sensor sends the emontx paket to RasperryPi and he replies
with an ack?
Many thanks

Regards

Juergen

Oh right, I didnt realise this. I have send you a RasPi3 + pre built SD card. Please use the unit to try and debug, the WLAN interface is working. Please send the unit back to us when you are done.

There must be something different about your setup, we have never had any other rapi3 with wifi that does not work like this.

Please start a new topic for your new question below.

See here for an overview of how emonPi works: https://guide.openenergymonitor.org/technical/

We use MQTT to publish messages between processes. This is a publish - subscribe protocol.