Community
OpenEnergyMonitor

OpenEnergyMonitor Community

"My electric" switched from end-of-prev-day to cumulative-during-day after end of BST

Tags: #<Tag:0x00007f1bd80ffd20>

I have had a very basic installation for the past 7 or 8 months with an emonpi, single “probe” monitoring overall house power usage, and a tablet running the dashboard with the “My Electric” app open 24x7. No other customisation or anything - everything straight out of the box. No solar or anything else.

I’m pretty sure when I first set it up just before the switch to BST, the counter showing the “Today” kwh usage was showing cumulative usage throughout the day. I know at some point around when BST started this year, but am not entirely certain it was that very day, and all the way through summer until the clocks changed last weekend, the counter started showing the figure from the previous day. It must have updated daily at some point during the night, but I never got to see exactly when.

Now the clocks have changed again, it’s switched back to its original behaviour of showing cumulative usage during the day.

I have to be honest, I totally prefer how it is now. Is this some kind of known issue and I can keep it this way? (I’m not exactly sure which behaviour is the expected one.)

Thanks,
John.

Hi John, what version are you running? if you run an update, that might solve the issue. Also clearing the browser cache might solve it.

Certainly right now, my ‘Today’ is showing today’s cumulative total.

Thanks Brian - definitely wasn’t the browser cache, as I saw exactly the same from multiple different computers, some freshly installed.

I’ve now done a full update. Previously I was on version low-write 10.2.6 git commit 10.2.5-3-gf781bed0, emonpirelease emonSD-17Oct19, with the following modules: Administration | App v2.1.8 | Backup v2.2.4 | EmonHub Config v2.0.5 | Dashboard v2.0.8 | DemandShaper v1.2.6 | Device v2.0.6 | EventProcesses | Feed | Graph v2.0.9 | Input | Postprocess v2.1.4 | CoreProcess | Schedule | Network Setup v1.0.0 | sync | Time | User | Visualisation | WiFi v2.0.3

After the update, I can see some of the modules have been updated, so maybe that will fix it. Unfortunately, I won’t really find out for another six months haha.

Thanks,
John.

1 Like

Oh I see, you meant that on Sunday, the figure was wrong?

Ah, not quite. What I meant was during the entire summer months (ie during BST), “Total today” was always displaying the total amount used yesterday. Which was the correct figure for yesterday, just not today’s usage so far. And since Sunday, it’s gone back to how it was when I originally plugged it in and shows how much I’ve used so far today. Does that make sense? Hence, I imagine when BST starts next year, it might go back to the “alternate” less-desirable behaviour.

1 Like

I can confirm this - during BST, the ‘latest’ bar on the graph was always yesterday, and now the ‘latest’ bar is today, and growing as electricity is used.

This is on an emonPi Oct19 image, but updated regularly.