Community
OpenEnergyMonitor

OpenEnergyMonitor Community

MQTT user/password

Tags: #<Tag:0x00007fc9af06f128>

Is it possible to not have a user/password for the localhost mqtt port?

I’ve a wireless relay I’m installing to my system and it’ll use mqtt but whilst you can configure the broker host address, port, topics etc. there’s no facility to set a user or password.

I tried commenting out the user and password in settings.ini but after restarting mqtt, none of my existing feeds worked!

Hello @greentangerine I havent tried removing the password recently to remember the exact steps, but you may find the MQTT section on the service credentials page here useful, at least to give some pointers https://guide.openenergymonitor.org/technical/credentials/

If you enable anonymous access it should work with both.

1 Like

That worked; thanks.

2 Likes