Mqtt still in connecting

Hello everyone, thank you all for helping us.

I’m trying to send email alert via nodered but the MQTT nodes still in connecting, I tried both local host and the ip adress in the server but same problem.
Can you please help me ?

Capture d’écran 2022-12-09 171301

Capture d’écran 2022-12-09 171331
Capture d’écran 2022-12-09 171353

I may be wrong but isn’t the MQTT port 1883 not 1880?


localhost is the domain of the machine the instance of Node-RED is installed on which may, or may not, be the same as the address the emoncms Broker is.

Without more information on how this is setup, the question is impossible to answer.

If contacting the emoncms broker, then remember to set the security settings




when I use the 1883 it still disconnected, it’s not even connect

To put you in the context I have an Emonbase here with emontx, I want to build an alerting system who send emails when something goes wrong
So when I check the guides and the topics here I duplicate what they do and it’s not working.
Also I have a preinstalled alert system on an other emonbase here , when I create a new flow and duplicate the the first flow the same problem happened, still in connecting.
this is the preinstalled system

and this is the duplicate node with no changing, you can see see the ip adress above to check

Did you fill in the security details (as I said above).

thank you so much it worked. I forgot to fill in the security details