Community
OpenEnergyMonitor

OpenEnergyMonitor Community

MQTT connection in NodeRED

I am not really sure why the MQTT input blocks “emon/#” and “emon/emonpi/power1” are saying disconnected in NodeRED. I have not modified the example flow, and I can see the values for power being published in EmonHub. Is there something wrong with the topic names in NodeRED?

I have also tried to use the “Publish to MQTT” in the input configuration to publish after going through emoncms. I have not been able to connect this way either, and since trying this the first time and then deleting the process, I am now unable to add this process again. It does not give me the option when scrolling through the processes.

1 Like

Hi

I noticed the “Publish to MQTT” was no longer showing in Process.

I mentioned it in another thread and @TrystanLea replied:-

Aha that was an issue that was fixed recently, 1 but the fix is still in the master branch and not in the stable branch. Your welcome to switch to the master branch in the meantime:

cd /var/www/emoncms
git checkout master

Ian

Thank you

After switching to the master branch “Publish to MQTT” still does not show up as an option for me.

Hi Eric

I just switched to master works for me. Did you remember to do a git pull after switching?

Edit

I did also have to reboot Pi to get the MQTT running after the update.

Ian

I did do a git pull afterwards, and then rebooted. It is still not showing up though.

Already on 'master'
Your branch is up-to-date with 'origin/master'.

That’s very strange.

Maybe some other modules are not up to date.

Thanks to Brian Borpin who pointed this out to me.

There is an update script in the useful scripts repository. It will update all the different Modules that are not included as part of the core - just check the hardcoded path.

emoncms/usefulscripts
usefulscripts - Some useful scripts for administering Emoncms accounts