Community
OpenEnergyMonitor

Community

MK2 PV it does not connect IDE


(Andrea) #1

Hello everyone, I apologize for my English because it is translated by Google, I’m new in the forum and I write because I recently mounted a card MK2PV Robin.
My problem is that with MACBOOK Arduino IDE does not see the port where the MK2 card is connected. I installed the “Silicon Labs” Drivers but the card is not seen. I use an Open Energy Monitor USB card.
I am attaching some pictures of the assembled board.
Thanks Andrea



Edit - rotated picture. BT - Moderator.


(Andrea) #2

As you can see my MacBook sees the USB card, but the Arduino IDE does not see the card.


(Bill Thomson) #3

Hi Andrea,

Have you tried swapping the Tx and Rx lines between your Mac and the interface board?

Have you tried getting support from Robin at his website?
(www.mk2PVrouter.co.uk)


(Andrea) #4

Hi Bill, I was able to load the sketch with a friend’s Windows, now I’m trying to figure out how to do with Mac.
I did a lot of tests … including that of exchanging RX / TX but not signs of life.
From what I understand you should create a virtual port with another COM …
I already asked Robim but he also advised me to write here because the USB interface is marked “openenergymonitor”.


(Paul) #5

I think you would get better advise on either the Arduino forum or a Mac forum.

It maybe just a different device naming strategy, a similar thing used to happen on a Raspberry Pi until a symlink was added.


(Andrea) #6

Sure Paul, I was hoping someone had my same problem …


(Robert Wall) #7

I think @Jon uses a Mac - he might be able to help.


(Jon Murphy) #8

Hi all! The Mac side looks correct. I see the same information on my Mac with the OEM device. The Arduino IDE setup may be incorrect.

Go to the Arduino IDE menu Tools > Board. What board setting is needed by the MK2PV?

Go to the Arduino IDE menu Tools > Port. What Port setting is needed by the MK2PV?

Disclaimer: I do not know anything about the MK2PV. And I rebuilt my computer last month and do not have access to Arduino IDE at the moment.

EDIT: it looks like the correct settings for the MK2PV are here:
http://mk2pvrouter.co.uk/13701.html

The programming facility for any Arduino-type hardware is known as the Integrated Development Environment (IDE). Within the Arduino IDE, various adjustments may be required before any new code can be successfully uploaded:

- The Tools->Board setting should be “Arduino/Genuino Uno”.
- The Tools->Programmer setting should be “AVRISP Mk11” (for any programmers that I supply).
- The Tools->Port setting should match whichever new port appears when the programmer is connected to the host computer.

NB. To see the results of any Serial.print() statements, the baud rate of the Serial Monitor must match the Serial.begin(<baud rate>) command in the sketch that is running . To open the Serial Monitor window, click the “magnifying glass” icon on the main IDE screen. The baud rate can then be changed using the drop-down menu. My software always operates at 9600 baud.


(Andrea) #10

Thanks Jon, I know the IDE well enough and the basic settings are correct, I also installed the “silabs” Driver as re-posted on the site you posted. The problem is that when I go to select the door … there is no door to select


(Jon Murphy) #11

I loaded up the Arduino IDE and I see this for the port/door. What do you see?


(Andrea) #12

this is my problem, you can not see anything …

but on the system settings the USB port sees the card

impostazioni%20usb


(Jon Murphy) #13

the driver did not load properly on the Mac. Download from here:

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers


(Andrea) #14

Already done


(Jon Murphy) #15

do you get a message the driver was blocked? (I am assuming you are running a current version of the macOS.)

If yes, then you’ll need to “allow”


(Andrea) #16

You are a wizard!!!

THANK YOU, I checked the loading of the system software, in the folder I found the “SILABS” drivers. NOW WORKS!

I hope it can be useful to others too.


(Jon Murphy) #17

yay! I am glad it worked!


(Robert Wall) #18

Thanks, Jon.


(Bill Thomson) #19

thumbsup Jon!

I marked it as the solution.


(Robin Emley) #20

The Atmel 328P processor on my Mk2 PV Router PCB is programmed in just the same way as the emonTx. I’ve added a link to this helpful thread from my website
mk2pvrouter.co.uk


(Robert Wall) #21

The full instructions have now been added to “Learn”:
https://learn.openenergymonitor.org/electricity-monitoring/arduino-ide/macoside#installing-the-arduino-ide-–-macos