Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Message: Error: Could not save Dashboard. Dashboard not updated

Hi All
I seem to be getting the below error message when trying to save a dashboard.
It seems to be caused by creating duplicate “Feed Values”

For anybody who runs into this problem in the future, I was hitting the SQL limit on the table that the dashboard saves too. The solution was to change the SQL table properties from TEXT to LONGTEXT

I think @Trystan needs to know about this.

My dashboard is as below, I take it that I must have the most complex dashboard then :joy:

Hi Dave, unfortunately I am not very skilled with SQL, but have the error you described on a dashboard, can you create a step by step guide on how I can change the SQL table properties from TEXT to LONGTEXT. Thanks for your efforts.

here are the steps I have taken today:

  1. sudo mysql -u root -p
  2. show databases;
  3. use emoncms;
  4. show fields from dashboard;
  5. ALTER TABLE dashboard MODIFY content LONGTEXT;
  6. show fields from dashboard;
  7. quit
    hope it is so correct

Hi All!
Sorry for my bad English.
I have updated the emoncms I have on a linux web hosting.
It worked fine for a long time, but with this update, I can’t save editing dashboards when they have graphic / visualisation elements. Works fine with all widgets, text, containers, etc., except visualization elements (graphs). This error appears when I try to save the dashboard:

Capturar

This happens whether I use “branch master” or “branch stable”.
I’ve already tried doing the above procedure, change the SQL table properties from TEXT to LONGTEXT, but it didn’t work.

If possible, I would be very grateful if someone could guide me, where should I start a screening route.

Additional data:

EMONCMS
Version 10.4
Modules
Administration | App v2.2.7 | Dashboard v2.0.10 | EventProcesses | Feed | Graph v2.1.0 | Input | CoreProcess | Schedule | Time | User | Visualisation

SERVER OS
Linux 3.10.0-962.3.2.lve1.5.52.el7.x86_64

HTTP Server
Apache HTTP/1.0 80

MYSQL
Version 10.2.37-MariaDB-cll-lve
Host localhost (127.0.0.1)

REDIS Version
Redis Server 3.2.12
PHP Redis 5.3.2

PHP Version
7.4.16 (Zend Version 3.4.0)

The solution for me was to change the SQL table properties from TEXT to LONGTEXT