Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Making PV Divert the default

Tags: #<Tag:0x00007fc0abb70188> #<Tag:0x00007fc0abb77780>

Hi all,

I’m a newbie who’s just got my system set up and running (thanks for the help @glyn.hudson ).

My setup: 4.7Kw SolarEdge system with monitoring (ethernet). OpenEVSE charger & EmonPi (both wifi). Small-ish house, good wifi coverage.

My ideal situation is that I leave the car plugged in as much as possible, and it only charges either: When there’s excess solar to use up (I believe anything over 1.4kw will start the charging), or when there’s excess power in the grid to be used up (this is being managed separately as part of a PowerShaper trial).

The important part for me is that we only use solar for charging unless I manually switich to full-power charging. We don’t do many miles and I want to make sure those miles are as green (and cheap…!) as possible.

I’ve got my EmonPi connected and PV Divert works, but it doesn’t seem to remember my divert setting. If the car’s not been plugged in for a day or so, it defaults back to full-power charge.

There’s also an issue with trigger levels… At this time of year we can see some small peaks in solar when the sun comes out, only for it to go back in again for 30-40 mins…! The peak seams enough to trigger the charger, but then it doesn’t turn off when the sun goes in. I understand this may be to limit the wear on the charger, but I’d like some control over the trigger levels…! Is this possible?

For reference, my coding ability is slim to none so I’m limited to making adjustments within the GUI. I’ve had a look round but don’t think I can see anything to either force a permanent PV Divert mode or adjust the trigger levels.

Thanks in advance for your help.

This should not happen, EcoMode should stay enabled. Try updating to the latest FW, you can do this via the OpenEVS web interface : https://github.com/OpenEVSE/ESP32_WiFi_V3.x/releases/download/3.3.1/firmware.bin

Correct, this ‘Minimum charge time delay’ is to avoid cycling the EVSE or EV too much. You can adjust this if you enable advanced settings on the OpenEVSE System tab. Then under Services > MQTT you will see these extra options.

Thanks very much Glyn.

The software update seems to have changed quite a few things around, the above options are now available.

Would you mind providing a more entry-level explanation of what the attack/decay numbers do?

Also if you’re open to feedback, it might be helpful to have the default numbers in the description, and maybe a warning about minimum charging time (i.e. reducing the minimum charge below X seconds will void the warranty)…?

I’ll feedback in the next few days if the PV-divert memory problems are solved.

Thanks for your help.

Great, good to hear. Good idea.

These adjust how responsive the smoothing algorithm responds to changes in solar PV / grid excess

Adjusting these settings won’t void the EVSE warranty. I’m more concerned about the effect on the EV of stopping / starting a charge many times quickly. Inside the EV there will also be a contactor that is more expensive and more difficult to replace than the one inside the EVSE.