Community
OpenEnergyMonitor

Community

Lost SSH access after changing emonPiLCD.cfg file

I’ve been logging in fine via SSH with my own password for months.

Today I changed some of the emonPiLCD.cfg defaults and rebooted (from the web Admin page).

My LCD changes worked, but now I can no longer SSH in.
“Permission denied, please try again.” – acting like the password has changed (?)

Very weird. I have tried to Disable SSH via the LCD button and then Enabled SSH again, but I still can’t SSH login anymore. I also tried the old default SSH password “emonpi2016” – no luck. Why would my SSH password access stop working?

The changes I made to the emonPiLCD.cfg file:

backlight_timeout = 0
default_page = 3
feed1_name = Volt
feed2_name = Tesla

(no change to other lines)

-Neil

Hi Neil, Welcome,

I’ll start with the obvious;

  • Login as user pi?
  • Caps lock off, number lock on if you use the numeric keypad?

I don’t know of anything that would have changed the SSH password. Disabling and enabling the SSH access would not change the password.

Are you definitely using the pi username and associated password, not the one for the admin page? They’re usually not the same unless you deliberately made them so…

Good suggestions, I also tried a different laptop in case a key wasn’t working on the keyboard – still could not get in. I’ve been using UNIX and Linux for years and this login failure is really weird.

Yes, same ssh [email protected] that was working just before the reboot, and yes very different from the web UI login, which still works.

You have only that one IP address active? (i.e. the IP addresses haven’t been moved around by your router, and you’ve got the wrong physical device?)

Failing SD card?

Emoncms UI still shows it on the same address - wired Ethernet, router hands out a static DHCP address for emon-pi.

Also double checked my router, no new stray emon-pi addresses.

As far as failing SD card, it does not show any other errors on emoncms, but I am suspecting I may need to re-build a new SD card to get back to normal – was hoping this SSH loss had been seen before.

Try logging in with a keyboard and monitor attached. Is sshd definitely running?