Login returns a 0 reply

I cannot login to emoncms.org.
I get a zero response after loggin with the correct username and just-received new password.
What am I doing wrong.
Tried multiple browsers on multiple computers.

Additional info:
I can login with a browser from my phone.
I cannot login with a browser from my computer.
What could I be doing wrong - I cleared the cache from my computer browser - no luck

My thoughts would be in the direction of the character set that you have on your computers - is it different to the phone?

I know in the past there have been difficulties where the user name or password was “long” (I do not know what the limit is) or contained characters outside the range 0x20 to 0x7e ASCII. I thought that these problems had been fixed.

I asked the emoncms.org system for a new password and the system sent me something like this:
Quite long indeed.

I’ll look into the character set issue.
I store these passwords in a BitWarden fault and copy them into the password field.

The Brave Browser is a bit more verbal in it’s error messages:

0 NetworkError: Failed to execute ‘send’ on ‘XMLHttpRequest’: Failed to load ‘https://emoncms.org/user/login.json’.

It started working on Firefox after I loaded a JSON extention.
Don’t know whether it will keep on working.

That seems to fit with what I read (not that I’m a networking expert) when I searched for the error you saw.
I tried my emoncms.org with an 18-character pasword and Brave browser “out of the box” (no add-ons or extensions) with no problem.

Solution I thought I had doesn’t work reliably.
The issue seems to be a new (?) way firefox handles this topic:

I am not competent to elaborate any further.

Impact is an unreliable / unpredictable login sequence.
Moving to another browser does not help but gives more elaborate error reporting.

Running Firefox 95 on mac osx 10.13.6

Think I found a work around.
Added the CORS extention to my browser.
By switching it on, the browser has acces to the required login proces.

CORS extention is here:

This sounds like something that needs @TrystanLea 's attention.

Yes that might be a good idea.
Don’t know how to draw his attention to this issue.
I believe he casts a keen eye on this forum on a regular basis.
Who knows what might happen.

Other thing is the following.
I recently updated my cofiguration.

Lost much of my node data on the central database.
Re-establishing the contact is a bit of a feat.

Mainnode is running, but the others are no-where in sight on the emoncms.org site / input page.
So the inputs page of my emoncms.org data set is more or less empty.

One might think that emonhub is struggeling to pull it’s weight.
As the api-key is being transferred for authentication - could this be a related problem?

The @[his user name] is enough to notify him - so no need to do anything more.

Thanks for the heads up on this @Antoine_Maartens, Im still not quite following what’s going wrong here and I cant replicate the behaviour. Did this start happening after you upgraded to Firefox 95? Im currently running 94 here…

That is correct Trystan.
It started with 95.

Firefox 95.0 64-bit (Ubuntu) works here for me, also Brave Version 1.32.115 Chromium: 96.0.4664.93 (Official Build) unknown (64-bit).

Mine automatically updated to 95 this morning and appears to be working fine too…

Actually, looking back through some other support questions on this same topic, the issue might be using https://www.emoncms.org instead of https://emoncms.org, and I can replicate this error specifically by doing that, looks like something I need to look into that to see what’s going wrong

This is exactly what I do as the emonevse interface uses this format too

Confirmed for me too (Brave, Opera, Chromium & Firefox browsers).

I accidentally tried to log in with https://www.emoncms.org - and it’s still returning a zero error.