Community
OpenEnergyMonitor

Community

Local Ubuntu Emoncms - Can't Sync from EMONCMS.ORG

Tags: #<Tag:0x00007f6e04d4f3e0>

I have created a local install of Ubuntu Emoncms on a 32bit x86.

Most things seem to be working well except I want to sync the Feeds I have on emoncms.org.

I have read through many times the very similar situation in Local Ubuntu Emoncms and Redis

The biggest problem I seem to be having is the lack of error messages.

Configuration via php-info.php:
PHP Version 7.0.30-0ubuntu0.16.04.1
Redis Version 3.1.6
Available serializers php
I suspect I might have an issue with the version of Redis php file, but I can’t find anyway to see what that is.

When I try running: sudo php sync_run.php it shows

SYNC: Starting
SYNC: Home dir: /home/craig
SYNC: Connected to Redis

On the emoncms/sync/view page when I enter the Host: https://emoncms.org, with the username and password, then hit connect it shows “Connecting to remote emoncms server…”. The text then disappears and there is no list of feeds.

Any ideas or suggestions would be greatly appreciated.

All that info is available on the Admin page of emoncms, there is also a “copy to clipboard” button to copy that info to a forum post (in a collapsed table) for us check for you.

Thanks. Didn’t realise that was there.

If I am reading it correctly I have a different versions of Redis (3.0.6) to the php Redis (3.1.6).

Server Information
Emoncms Version 9.8.31 : 2018.06.21
Modules Administration : App v1.1.0 : Dashboard v1.3.0 : EventProcesses : Feed : Graph v1.2.0 : Input : CoreProcess : Schedule : sync : Time : User : Visualisation
Server OS Linux 4.4.0-116-generic
Host ubuntu ubuntu (127.0.1.1)
Date 2018-07-01 10:21:06 AEST
Uptime 10:21:06 up 4 days, 21:05, 1 user, load average: 0.02, 0.33, 0.33
HTTP Server Apache/2.4.18 (Ubuntu) HTTP/1.1 CGI/1.1 80
MySQL Version 5.7.22-0ubuntu0.16.04.1
Host localhost (127.0.0.1)
Date 2018-07-01 10:21:06 (UTC 10:00‌​)
Stats Uptime: 385499 Threads: 1 Questions: 593715 Slow queries: 0 Opens: 750 Flush tables: 1 Open tables: 416 Queries per second avg: 1.540
Redis Version 3.0.6
Host localhost:6379 (127.0.0.1)
Size 49 keys (426.23K)
Uptime 4 days
Memory RAM Used: 11.97% Total: 1.96 GB Used: 240.05 MB Free: 1.72 GB
Swap Used: 0.00% Total: 501 MB Used: 0 B Free: 501 MB
Disk Mount Stats
/ Used: 26.90% Total: 6.79 GB Used: 1.83 GB Free: 4.6 GB
PHP Version 7.0.30-0ubuntu0.16.04.1 (Zend Version 3.0.0)
Modules apache2handler : apcu v5.1.3 : calendar v7.0.30-0ubuntu0.16.04.1 : Core v7.0.30-0ubuntu0.16.04.1 : ctype v7.0.30-0ubuntu0.16.04.1 : curl v7.0.30-0ubuntu0.16.04.1 : date v7.0.30-0ubuntu0.16.04.1 : dom v20031129 : exif v7.0.30-0ubuntu0.16.04.1 : fileinfo v1.0.5 : filter v7.0.30-0ubuntu0.16.04.1 : ftp v7.0.30-0ubuntu0.16.04.1 : gd v7.0.30-0ubuntu0.16.04.1 : gettext v7.0.30-0ubuntu0.16.04.1 : hash v1.0 : iconv v7.0.30-0ubuntu0.16.04.1 : igbinary v1.2.2-dev : json v1.4.0 : libxml v7.0.30-0ubuntu0.16.04.1 : mbstring v7.0.30-0ubuntu0.16.04.1 : mcrypt v7.0.30-0ubuntu0.16.04.1 : mysqli v7.0.30-0ubuntu0.16.04.1 : mysqlnd vmysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $ : openssl v7.0.30-0ubuntu0.16.04.1 : pcre v7.0.30-0ubuntu0.16.04.1 : PDO v7.0.30-0ubuntu0.16.04.1 : pdo_mysql v7.0.30-0ubuntu0.16.04.1 : Phar v2.0.2 : posix v7.0.30-0ubuntu0.16.04.1 : readline v7.0.30-0ubuntu0.16.04.1 : redis v3.1.6 : Reflection v7.0.30-0ubuntu0.16.04.1 : session v7.0.30-0ubuntu0.16.04.1 : shmop v7.0.30-0ubuntu0.16.04.1 : SimpleXML v7.0.30-0ubuntu0.16.04.1 : sockets v7.0.30-0ubuntu0.16.04.1 : SPL v7.0.30-0ubuntu0.16.04.1 : standard v7.0.30-0ubuntu0.16.04.1 : sysvmsg v7.0.30-0ubuntu0.16.04.1 : sysvsem v7.0.30-0ubuntu0.16.04.1 : sysvshm v7.0.30-0ubuntu0.16.04.1 : tokenizer v7.0.30-0ubuntu0.16.04.1 : wddx v7.0.30-0ubuntu0.16.04.1 : xml v7.0.30-0ubuntu0.16.04.1 : xmlreader v7.0.30-0ubuntu0.16.04.1 : xmlwriter v7.0.30-0ubuntu0.16.04.1 : xsl v7.0.30-0ubuntu0.16.04.1 : Zend OPcache v7.0.30-0ubuntu0.16.04.1 : zlib v7.0.30-0ubuntu0.16.04.1
Client Information
HTTP Browser Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36
Screen Resolution 1680 x 1050
Window Size 1663 x 908

That’s fine they are different things and their versions run independently, there is no need to “match” the version numbers.

The fact the redis section is there in the server info means redis is enabled and likewise the fact that redis appears in the php modules section tells us the phpredis extension is enabled.

The later v4 of phpredis is untested and reportedly may have code breaking changes, so you are on the latest known good version 3.1.6, which is also correct for php7.

This leads me to believe you may have just a sync issue and that redis is fine.

Have you installed the service-runner as outlined in the sync-module’s readme?

@whatsupskip do you have any local feeds?,

and if you enter an incorrect password, do you get the “Authentication failure, username or password incorrect” alert?

Yes, I have local feeds and they are working fine.

Also when I used the incorrect username I received the Authentication failure.

Thank you for these suggestions.

Very strange. While double checking the set up of the service-runner. I tried running the sync function on the /emoncms/sync/view page and this time it logged in and listed the available remote feeds.

I did make some changes to the firewall and mySQL ability to accept remote connections. This could have been the required change.

I wasn’t able to download from the remote (emoncms.org), but from the command line it has worked.

This is all I really need as I only want to download historic data.

Thanks again for all your help.

1 Like