Local emonpi out of sync with MQTT?

You need to post it as text, please.

The info does need to make sense. Looks like the emoncms log level isn’t set to DEBUG.

You always get those warnings.

So is the time on the Docker MQTT, correct?

I’m unclear what settings you have on MQTT Brokers, emoncms & emonhub.

emonhub → Docker MQTT ← Emoncms - there is a delay
emonhub → EmonPi MQTT ← emoncms - no delay

If so looks like an issue with your Docker MQTT setup.

Did you change the settings for emonhub & emoncms to point to that Broker & restart both or did you just stop the Docker?

ah sorry I haven’t been clear.

Here’s what I had. The dotted lines show the 2nd instance (docker) of emoncms connected to my primary MQTT. When I shut the docker emoncms down then the problems disappeared.

Quite possibily, the NAS does not have the processing power to do both then.