Issues with Post Process Module

Hi there,

I have been struggling to use the basic_formula in the Post Process module and want to share my experience and see if anyone can offer any alternate explanations, or update to the guidance documentation.

I am running emoncms 10.2.3 on a RPi3 running emonSD-17Oct19, with Post Process module version 2.1.4

Issue1: My initial requirement is to invert the values in some feeds, so using the ‘basic_formula’ option, I just wanted to multiply the feed by -1. However, no matter which feed I specified I always got the same error message:

STOPPING could not understand your formula SORRY....

Eventually I tried it the other way around:


and this worked! Although the examples do show numbers first and then feeds, the guidance notes don’t say that this is a requirement, if this is the case, could the notes be updated?

Issue 2: Once the process has been created, and appears in the list, I can click the Run Process button to run it, and sometimes the window showing the postprocess logfile will update and show the results, and sometime it remains static, showing the results from the previous run. I was tailing the postprocess.log file via an SSH session so I knew it had worked. There is an Auto Refresh button and sometimes this updates the window, but I cannot tell whether the Auto Refresh button is ‘selected’ or not as the colour and message in the button doesn’t seem to change. How about changing the text in the button to show a status of on or off?

Issue 3: Once the process has run, it remains visible in the list of processes in Post Process module, with a dynamically updating counter showing how many points behind it is. I have two processes, both for powertokwh, and when the counter for the first process reaches 30, it appears the process runs automatically, and the counter goes back to 0. But the 2nd powertokwh process never runs automatically. The first process was created quite a while ago, maybe a year or more (I can’t remember) and the 2nd was created today. Does this explain the different behaviour?

Issue 4: Sometime when I press the Run Process button, the log says

output feed already up to date

It looks as though if the counter is less than 30, then the feed is classed as being up to date? If so it would be good if this was mentioned in the guide.

Issue 5: This is a minor point, but when selecting basic_formula, a line of green text appears:

check you feeds numbers before

I presume this is a warning to check the feed numbers are correct, and just needs tidying up?

Ultimately I have managed to invert the feeds, but wanted to share in case this helps anyone else.

Regards. Ian