Issues with EmonScripts

Yes, lots of errors. They might be down to my lack of knowledge of how things need to be set up. Probably better if I DM you a copy of the console output from a run of the script.


I’ve moved this to a new topic @Bramco

What base system did you use?

The latest Raspbian with desktop as I wanted to copy the SD to a hard drive - it’s then easier to mess around with the partitions with GParted.

I’ve sent through a long list of errors, failures and warnings etc.

And I was only playing with Docker because I thought that if the scripts threw errors and failures, then maybe the Docker image would be a way forward - obvs not as I found out.


A pretty unique case and not something the scripts support. Sorry.

You can used the EmonSD Image on an SD card first, then use raspi-config to move it to the SSD (I think), but the GUI is not available on that image.

Not really - I can imagine more users wanting to move everything to SSD or a hard drive. It was certainly supported in the past, in terms of instructions - before the scripts came along.

Raspi-config doesn’t include the utility to clone the image onto an SSD or hard drive.

I tried this a while back with another utility and it didn’t work - this was the result of an attempt late last year → Redis failed on boot - new system on USB drive - #6 by borpin


I was sure I’d come across this recently, obviously not. Perhaps I’m thinking of DietPi.

This seems a pretty good guide to moving.

How to Boot Raspberry Pi 4 / 400 From an SSD or Flash Drive | Tom's Hardware.

TBH, on an SSD, I’d simply use the Ubuntu method and not include the data partition or log2ram.

I think you used the 64bit not 32bit image.

I think that’s what I followed before Xmas when I ran into the Redis mularky.

Maybe that should be the advice for anyone wanting to go down that route?

And maybe - I’ll use the 32bit and check.


I did try the 64bit and did run into some issues but cannot remember what.

My build was on the bog standard 32bit image with the desktop. It fails.

Sorry for the delay in replying, we had a busy weekend.


Needs to be the lite image (as per instructions).

Realize that Brian, I was just responding to the question you asked which I said I’d investigate.

Strikes me as odd that the scripts work on the Lite version but not on the version with desktop. I thought the Lite version was basically the full version without the desktop and some of the apps?

And I guess my PoV is that the scripts should work on either base version of Raspbian. It’s like the issue with the zero that someone posted about today.

If they can’t be made to do this, then there should be a clear instruction/statement at the top of the page about the scripts that they ONLY work with the following conditions. Not a zero, lite version only etc. even then the fix for log2ram needs to be included.