Issues flashing v440 boards

Hi all,

I’ve been having serious problems flashing v440 boards. They programmed through the control board first time ok, but never established proper communication with the controller. I also don’t see them blink the blue led every 8 seconds. I tried reprogramming them with lower baud rate images, but that fails. I can’t reprogram them… the controller board gives errors that the device id isn’t recognized (i think the boards just don’t respond).

I then got a usbasp programmer and tried programming them that way on platformio, but the v440 boards are not responding.

Uploading .pio/build/V440/module_fw_V440_attiny841_440_eF4_hD6_l6C.hex

avrdude: set SCK frequency to 93750 Hz
avrdude: error: program enable: target doesn't answer. 1 
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

*** [upload] Error 1

The controller seems to function properly. I can access the web pages, and when it connect rx to tx the led lights up blue and I see lots of ignored packets (as expected).

I got 20 boards, and tried a few with different soldering techniques as well, but none of them work.

Any clues to get the v440 boards to behave? I’ve been thinking to go the route of high-voltage fuse resets and funny stuff like that, but thought I’ll check here first. Bad batch of attiny841’s? Is that even possible?

Thanks for any pointers!
Tom.

Quick update. I did end up desoldering the attiny841 from the board and was able to read and write fuses from it with a high-voltage programmer. Interesting was that the fuses were still set to their default even though there was this one time successful programming through the controller board.
So now I set the fuses as expected by the v440 board, soldered the chip onto the board again. When I now programmed it through platformio/aspusb it worked! I was very happy to see all write and verify steps succeed… however: no blinking led every 8 seconds! When I tried to reprogram it failed again.

I have no clue what’s going on… next step is to desolder the chip again and test it entirely on its own before soldering again. Just have to find the time :frowning:

If anyone has seen this behavior (or lack of behavior) I’m interested in your experience.

Regards,
Tom

Hi Tom,
I’ve got a new controller and modules (all v4.4). The controller is the latest revision too.

I’ve flashed my ESP32, have configured the controller and can access it on port 80. All good there.

I’ve flashed a few of the modules using the controller (they say successful). I immediately disconnect the ISP cable and reboot the controller.

I connect the tx to rx and rx to tx, forming the loop.

For testing, I’ve powered the controller with 5v and have powered the cell module with 3v from the same supply. I clicked on the 9.6k speed file when programming the cell module and have configured 9.6k as the comms speed in the controller.

No matter what I do, I can’t get the controller to see the modules. The blue LED on the module blinks twice every 8 seconds but that’s all. I don’t see any data blinks and the controller will not recognise the modules.

I’ve tried two controllers and three modules and have had no luck with any of them.

I’ve tried flashing modules for standard speed as well as 5k and 9k. I’ve tried different data cables and I’ve tried two ESP32’s.

I’ve posted this in the v4 channel in the hopes @stuart can offer up some advice.

I’d be willing to accept that maybe I killed a tiny84 once through overheating but not several, especially when all say successfully programmed.

I’ve not tried programming the tiny84 without the use of the controller yet.

Thanks in advance.

Please DO NOT cross-post. All it does is dilute any responses you might get, and that will lead to yet more confusion. I’ve deleted the near-copy and inserted a ‘@mention’ for Stuart above.

Thanks. (Moderator - RW)

@jamesjames it looks like you have done most of the basics.

The flashing blue led every 8 seconds is a good sign - it means the modules are working as expected, and code is running.

If you loop the TX to RX on the controller, do you see a change in the web interface - the “OOS” errors should increase.

Test the modules using the standard code for now to rule out any speed issues with higher baud rates.

When you built the controller/modules, did you substitute any parts or did JLCPCB suggest alternatives?

Hi @Stuart,

Thanks very much for replying.

I’ve connected tx to rx on the controller and I see no changes anywhere. Please would you explain to me what OOS errors are and where I’d find them. The red bar across the top of the page remains. The one that’s waiting for a module to connect.

I was going to post a screenshot of the serial console but forgot to bring it with me to work and so I’ll do that tomorrow.

I had the boards made at JLCPCB and I did not need to substitute any parts. I don’t recall if JLCPCB tried to suggest alternatives but as it doesn’t ring a bell, I’d say not.

Ok. You would see the OOS error count (if there were any) on the screen it automatically appears.

So this suggests a problem with the controller circuit soldering or with the JST cables you are using.

Where did you get the JST cables from?

You need to make sure they are straight through cables, so pin 1 to pin 1, 2 to 2.

If you have brought them premade I suspect this is where the problem lies.

I’ve been doing a lot of testing since I first reported here. The controller board appears to work fine. When connecting RX to TX, the led blinks blue and I see the ‘ignored requests’ counter go up.

For the modules, it looks like there’s a problem with the external clock. When I flash the default image, then the module fail immediately and I can’t get them to reprogram even. Only when I reset the fuses (using high voltage) to use the internal clock I can reprogram them again. I’ve installed platformio and uploaded the v4.4 firmware but using default internal clock and then the module does communicate with the controller board. However, comms is very unreliable and fails most of the time. It’s unusable.

I’m not sure what next step to take… I desoldered an oscillator and tested it using a signal generator, and it does amplify 8Mhz just fine. So somehow the attiny841 isn’t working well with the oscillator. I’ve also ordered a new set of attiny’s thinking maybe I got a bad batch, but replacing them doesn’t help either.

Any suggestions are welcome.

Hi @Stuart,

Thanks for the advice. The JST cables were bought premade from eBay. I’ll check when home in a couple of hours and report back to you.

Thanks again for your ongoing support, I really appreciate it.

James

Hey Tom,
I’m sorry for hijacking your post. All being well you get some assistance shortly.

James