Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Is it possible/sensible to disable wifi?

I have a single emonPi, connected to local network via Ethernet cable. No Wifi required.

I see that the Wifi is on and scanning other Wifi networks. Would it be sensible to turn the Wifi off seeing it is not used in my context? If so, how can the Wifi be turned off?

Hi Juerg,

Yes, it’s a good idea to disable a network interface you don’t use.

From: https://raspberrypi.stackexchange.com/questions/43720/disable-wifi-wlan0-on-pi-3

To completely disable the onboard WiFi from the firmware on the Pi3, add
dtoverlay=pi3-disable-wifi in /boot/config.txt. This is documented here.
Be sure to use up to date firmware as this feature was committed recently.

Thanks @Bill.Thomson. Done all that and rebooted emonPi, but in the local Administration/Wifi page, it still is listing the scanned Wifi networks it finds. Looks like the Wifi is still active. I believe I have the latest firmware - also because the dtoverlay=pi3-disable-bt was already in the config.txt file.
Any ideas what is not working here?

Have you forced a browser page reload to ensure you’re not looking at cached data?

Just to be sure we’re on the same sheet of music…
We’re talking about the built-in wifi, vice an add-on device, right?

Yes, did reload the page. It appears as if my change to the config.txt file has no effect so far.

And yes, we are talking about the standard built-in wifi, no add-on. Strange. Then again, I’m a newbie, so I may have missed something obvious.

Do you mean “dtoverlay=pi3-disable-wifi” not “dtoverlay=pi3-disable-bt”?

Bill said

Sorry for not being preciser in the first post:

When I opened the config.txt for the first time, I found that the “dtoverlay=pi3-disable-bt” was already there. My aim is to turn off the wifi too, so I added a “dtoverlay=pi3-disable-wifi” and rebooted.

I was surprised to see a list of available wifi networks in /Setup/Wifi.

In the meantime I found that the wifi is actually turned off, i.e. not listed when running command ifconfig.

Nevertheless, the available wifi networks are still listed. Perhaps this is just a cosmetic flaw and it remembers previously scanned networks?