Community
OpenEnergyMonitor

Community

Iotawatt issue uploading data to emoncms since last week

Tags: #<Tag:0x00007f6e0375f058>

Hey Guys,

I’ve had the IoTaWatt posting to emonCMS for almost a year now, and last week we had a power outage and the data has not been able to be recorded on emonCMS since. I’ve tried restarting it several times.

I can, however, see from the local device (http://iotawatt.local/) that it is running/recording:
image

I’ve tried setting the “upload history from:” to a month ago in settings and no change.
Here is what the Message Log looks like:

** Restart **

SD initialized.
9/30/18 21:46:10z Real Time Clock is running. Unix time 1538343970 
9/30/18 21:46:10z Version 02_03_13
9/30/18 21:46:10z Reset reason: Software Watchdog
9/30/18 21:46:10z Trace:  1:4, 1:5[21], 1:6, 1:3, 1:4, 1:5[14], 14:0, 14:4, 1:6, 1:3, 1:4, 1:5[19], 1:6, 1:1[8], 1:2[9], 9:0[9], 9:0, 9:1, 8:4, 8:6, 8:8, 9:3, 9:4, 9:5, 9:9, 1:2, 1:3, 1:4, 1:5[3], 3:0, 3:6, 3:6
9/30/18 21:46:11z ESP8266 ChipID: 416960
9/30/18 21:46:12z Local time zone: 0
9/30/18 21:46:12z device name: IotaWatt, version: 3
9/30/18 21:46:12z MDNS responder started
9/30/18 21:46:13z You can now connect to http://IotaWatt.local
9/30/18 21:46:13z HTTP server started
9/30/18 21:46:13z timeSync: service started.
9/30/18 21:46:14z statService: started.
9/30/18 21:46:14z WiFi connected. SSID BELL482, IP 192.168.2.40, channel 11, RSSI -44db
9/30/18 21:46:14z Updater: service started. Auto-update class is MAJOR
9/30/18 21:46:15z dataLog: service started.
9/30/18 23:11:50z dataLog: Last log entry 9/28/18 06:33:25 
9/30/18 23:11:52z Updater: Auto-update is current for class MAJOR.
10/01/18 13:11:51z timeSync: adjusting RTC by -1
10/02/18 03:12:54z timeSync: adjusting RTC by -1
10/02/18 16:12:54z timeSync: adjusting RTC by -1
10/03/18 06:13:57z timeSync: adjusting RTC by -1

Thanks, help is appreciated !!

Bob Lemaire can now be found at https://community.iotawatt.com, he has set up a dedicated forum for IotaWatt, it might be more appropriate if you post your question there - I’m sure he will get back to you quickly.

you have hit the file log problem, there is a command to run, its listed on the iotawatt forum.