Invalid API key

I am getting ‘Invalid API key’
I double checked the key from the ‘Inputs’ device and also tried creating a new one.
tried different servers.
Emoncms - user login gives me ‘Invalid API key’ gives me ‘Invalid API key’
emonpi/emoncms gives me ‘Failed to connect’
Then I setup a Raspberry Pi with Emoncms and also got ‘Invalid API key’

anyone know what else I should try?

Your local emonCMS and are different, so each has their own APIkey.
And are you using the correct one? To send data, you must use the “Read and Write” APIkey, get it from “Input API Help” on the top right corner of the Inputs page.
You can test it in your web browser by copying into the address line the example whose description starts “To post data from a remote device …”, when you should see “ok” and back on the Inputs page, the three power values should appear.

instructions are simple, it is just not working

so if I click ‘show password’ here the dots disappear and field is blank, is this normal?, it acting like its not saving the key.

I tried searching forum for ‘post data from a remote device’ I could not find this example you mentioned.

Ok, so you got my attention when you said get the key from ‘Input API Help’ and that key worked, so many bad info online saying to click on the gear.
Thank you for the help.

Why did you search the forum? Read what I wrote again, slowly and carefully. Go to the Inputs page of emonCMS (either, they are the same in this respect). Look at the examples showing how to send data.

Please explain. Where exactly is “online” - link and where it is on the page please; and what do you mean by “many bad info”. If it’s in the OEM documentation, I can do something about it. If not, you need to take it up with whoever manages the resource where you found the “bad info”.

I will try to find the bad info, or maybe its just old, here is one.

I see the guides here on this site is correct, I was burnt out reading/watching videos by the time I found this site.

I can see very easily why you were confused - those instructions are, at best, “sketchy”. I’d have said totally inadequate.

I’m afraid there’s nothing that I can do directly, I’ll see if I can get the instructions changed.

I reported the error in their documentation to OpenEVSE Support. The ticket was most arrogantly closed with no response and no corrective action taken. You can read the ticket here:

So, I’m afraid @Firefly, it’s lesson learned: Come to the horses mouth for reliable information next time you have a query about emonCMS.

1 Like

I would recommend following the OpenEnergyMonitor guide for OpenEVSE Emoncms setup: OpenEVSE / EmonEVSE Setup Guide - Guide | OpenEnergyMonitor