Community
OpenEnergyMonitor

Community

Installing NodeRed on emonSD-30Oct18

emonsd
Tags: #<Tag:0x00007f16aa1ecab8>

(John Schols) #21

I haven’t added anything to the recently received emonSD-30Oct18. Is it possible that the emonSD has a problem?


(John Schols) #22

is this the expected output

emonSD-30Oct18
[email protected]:~ $ sudo dpkg --purge --force-all nodejs
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: package is in a very bad inconsistent state; you should
reinstall it before attempting a removal
(Reading database ... 45289 files and directories currently installed.)
Removing nodejs (10.14.0-1nodesource1) …
[email protected]:~ $

(Paul Reed) #23

Have you tried my suggestion above about replacing possibly corrupt list files?


(Brian Orpin) #24

OK so try

sudo dpkg --remove --force-remove-reinstreq nodejs

(Paul Reed) #25

It’s misleading having 2 people advising John at once, so I’ll leave it with you for now Brian.


(Brian Orpin) #26

Ok, I think the package itself is corrupt.


(Brian Orpin) #27

I edited your reply. It is 3 ticks on a line on its own, then the code (no more ticks) then 3 more at the end of the block on a line on their own.


(John Schols) #28

brian/Paul
Have restarted script and so far it has passed the place it was stopping at before. Will update if it finishes okay.


(John Schols) #29

All done.

Script finished. Thank you all for your help. :pray::pray::pray:


(Paul Reed) #30

So, what made the difference?
What did you do before running the script?


(John Schols) #31

I ran sudo dpkg --purge --force-all nodejs

before restarting the command


(Glyn Hudson) #32

Great to hear you got it sorted. Thanks for helping out guys :+1:

I’ve just testing again this evening with a fresh emonSD image and again it works first time. Something must have got messed up with @JohnSchols packages somehow.

I just followed the NodeRed RasPi install guide. It’s best for NodeRED to mentain their own install guide since steps may change over time: https://nodered.org/docs/hardware/raspberrypi


(Brian Orpin) #33

Agreed, but what I meant was that, as it will be quite common for users to want Node-Red especially those upgrading from the old SD image, it would be worth, in the How to Upgrade to New SD Image (that is a thing right…) that users are pointed to the ‘How to install Node-Red on Raspbian’ pages (having been instructed to enable SSH first of course).

I’ll get my hat…

:smile:


(Glyn Hudson) #34

Yes, there is already a note on the NodeRED user guide integrations page: