Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Installing emoncms to Zyxel NAS326

Hi

Is there anybody to succesfully installed emoncms to Zyxel NAS326?
The things I made:

  • installed PHP-MySQL-phpMyAdmin package to the NAS.
  • modified the /i-data/sysvol/.PKG/PHP-MySQL-phpMyAdmin/etc/init.d/PHP-MySQL-phpMyAdmin to disable md5 checking, and included apache Alias definition to the emoncms install directory and included emoncms to AuthZyxelSkipPattern
  • modified /etc/pkg_service_conf/httpd_zld2.conf by creating a Directory section to the emoncms install directory, and copied all the settings from .htaccess to this Directory config section
  • edited by hand the settings.php according to the example.settings.php

The login screen appears, but when tried to register, I got the following error:
404 Not Found: Is modrewrite configured on your system?

modrewrite is used by the NAS itself, and all the RewriteRule/RewriteCond lines exists in the Directory secton from the emoncms .htaccess.

Thanks

Zoltan

You should edit the ‘settings.ini’ file - settings.php is deprecated.

OK, I read the installation documentation, but without this I got an error:
Can’t connect to database, please verify credentials/configuration in settings.ini

Which docs?

The docs/*Install.md files

I’ll need the url as there are a number of different install docs.

The docs I mentioned are in the installation package.
Now I solved the modrewrite problem, and tried to reinstall emoncms.

The settings.ini still does not work.

What installation package?

Send some links as to where you got it from and what instructions you are following else I cannot help.

@pzozya
Please take a minute to read this point on the FAQ page:

And that is also true of the instructions. The way we do things changes over time. Sometimes, old instructions are copied and then not updated. Or there might be a different set of instructions for different hardware. You must tell us exactly which instructions you looked at so that Brian can find them and read them himself.

But which one?

I think I have an environmet issue. Tried to see the DebianInstall.md to identify the required components. I found, that the install require the php-pear module. But he Zyxel NAS326 does not have this module in his php package. I have two way now:

  • Try to install a new apache/php/mysql to my NAS
  • Leave the concept to use my NAS as a platform for emoncms