Installed new sd/restore/no inputs running

Hi did backup. Install newest version of sd from shop. restored. inputs do not appear to be running. What have I missed?

You’ve left a lot of necessary details out. For a start, which “inputs” and where are they coming from?

I’m running 1 emonpi and 2 tx3’s. emonpiRelease : emonSD-10Nov22
emonhub : Active Running
emoncms_mqtt : Active Running
feedwriter : Active Running - sleep 300s 0 feed points pending write
service-runner : Active Running
emonPiLCD : Active Running
redis-server : Active Running
mosquitto : Active Running
demandshaper : Not found or not installed
Version : low-write 11.3.22

Feeds not updated since backup which was restored.


sorry only thing I changed when I restarted (after new SD installed) was to connect to ethernet iso wifi, assume this would not have caused this

I think you are correct there.

How old is the version you updated from? and how old is the software in your emonTx’s?

What does the emonhub log say? Are you seeing anything? Ideally, you should see “NEW FRAME : OK” followed by the Node IDs of your emonTx’s and emonPi (5), then a stream of bytes (in decimal: 0 - 255); or the data and words that suggest the data doesn’t fit (I can’t remember the exact words now :frowning_face: )

If the latter, can we have a screenshot of the data that’s being rejected?

I’ve only ever bought the SD cards from the shop, I don’t think I’ve missed any version updates.

emonhub.txt (11.5 KB)
I’m not seeing any error messages.

emonhub log file attached.

This means nothing. I still don’t know what you were running successfully before you updated it.

And how old is your emonPi?

“2023-07-09 12:41:01,126 ERROR MainThread Could not connect to RFM69 module”

This is probably why you’re getting nothing from the emonTx’s and the Pi itself, because all the data comes in via the same route. What I need to find out is the settings your hardware requires. It’s likely that the last line in the excerpt here from emonhub.conf is wrong for the software inside the “emon” front end part of the emonPi:

### This interfacer manages the RFM12Pi/RFM69Pi/emonPi module
   Type = EmonHubJeeInterfacer
      com_port = /dev/ttyAMA0
      com_baud = 38400                      # 9600 for old RFM12Pi modules

You could try changing 38400 to 9600, and if this doesn’t work, to 19200 or even 115200.
EmonHub should restart after editing, you can always restart it manually with the orange button if in doubt.

Robert, I received your message last night and tried to log in via ssh. this didn’t work so i left the unit turned on last night. this morning i Tried resettting ssh (holding button 5 secs). No go.

So I powered down the unit. I started it again. This time everything started as if nothing had happened. I’ve lost some data. I reset ssh this worked okay also.

As a quick aside can you let me know the location of the setting.php file please so i can reset the ssh password.

Thanks for your help.

I’m afraid not, you need a Pi expert for this.